Cannot access the web apps with a given IP

I have installed Camunda Wildfly 10 distribution.
I deploy my process applications and I run the “camunda-bpm-wildfly10-7.6.0\start-camunda.bat” file which gives me access to http://localhost:8080/camunda/app/welcome/default/#/welcome

However, when I try to connect to the same address with my IP instead of localhost, that’s not possible.
What should I check/configure?

In also have a Camunda-Tomcat distribution installed and it works fine with both ways.


This is the default behaviour of wildfly. It only listens on localhost.
Got to the file standalone.xml and find Interfaces/interface with name “public”.
Change child element to <any-address/>.


Editing start-camunda.bat and changing
start standalone.bat
start standalone.bat -b
should also work.
With this you change the bind adress also from localhost to ‘any address’.


Hi @langfr,

How can we do sth similar with the “” file?


Edit: Okay, I just edited last line of that file into
/bin/sh "$(dirname "$0")/server/wildfly-10.1.0.Final/bin/" - b

It worked!

1 Like

Thanks @kontrag, I have used your solution and it works!

Another topic, do you know if Camunda Modeler has a web application to publish to Internet too?