Cannot open a DMN Table from Camunda

Hello Camunda community,
I am following through the Camunda tutorial and I did not find any option to activate the option to start a new DMN Table; I have the options for BPMN, DMN Diagram, CMMN Diagram, but none for DMN Tables.
Are the DMN tables available only in the premium version?DMN-Table_Not-Listed

Hi @quetzi,

in the latest version of the modeler they dropped the differentiation between Decision Requirement diagrams (DRD) and Decision Tables:

Everything is is a DMN diagram and if you double click a single box, you get the Decision table to edit.

Hope this helps, Ingo

I had checked it, but the structure behind a process after double clicking it seems to be different when compared to a decision table:

Or did the logic/structure change as well?
Thank you in advance,

@quetzi the documentation page needs to be updated. The DMN view which you’re seeing in the modeler is from the latest release. But functionally it’s same. It’s user interface change in the modeler.

thanks @Ingo_Richtsmeier @aravindhrs, it was more or less obvious, did not expect that the documentation is not up2date. I think I figured it out, but I somehow cannot finish the DMN tutorial, as I get an error after deploying on Tomcat:

This is my DMN model is:
dish_model.dmn (3.6 KB)
my Java class is:

package org.camunda.bpm.getstarted.dmn;

import org.camunda.bpm.application.PostDeploy;
import org.camunda.bpm.application.ProcessApplication;
import org.camunda.bpm.application.impl.ServletProcessApplication;
import org.camunda.bpm.dmn.engine.DmnDecisionTableResult;
import org.camunda.bpm.engine.DecisionService;
import org.camunda.bpm.engine.ProcessEngine;
import org.camunda.bpm.engine.variable.VariableMap;
import org.camunda.bpm.engine.variable.Variables;

@ProcessApplication("Dinner App DMN")
public class DinnerApplication extends ServletProcessApplication

    public void evaluateDecisionTable(ProcessEngine processEngine) {

      DecisionService decisionService = processEngine.getDecisionService();

      VariableMap variables = Variables.createVariables()
        .putValue("season", "Spring")
        .putValue("guestCount", 10);

      DmnDecisionTableResult dishDecisionResult = decisionService.evaluateDecisionTableByKey("dish", variables);
      String desiredDish = dishDecisionResult.getSingleEntry();

      System.out.println("Desired dish: " + desiredDish);


The tutorial link is:

The step I don’t manage to reach is:

Looking forward for an answer if possible,
thank you in advance,

@quetzi, your dmn model looks like this:

<decision id="Decision_0ceyqjg" name="Dish">
    <decisionTable id="DecisionTable_16t82ze">
      <input id="Input_1" label="Season">
        <inputExpression id="InputExpression_1" typeRef="string">

The decisionKey is “Decision_0ceyqjg”.

Change like this in your code:

decisionService.evaluateDecisionTableByKey("Decision_0ceyqjg", variables);

Thanks, it worked, it was successfully deployed. Still, the case definitions apparently aren’t recognized:

Attached also the .dmn file.
dish_model.dmn (3.6 KB)
What do you think it’s the problem?

This answer is already a month old and the Quick Start guide still has not been updated.
This makes a very bad impression when you just started evaluating the product and you cannot even finish the very first, very basic introduction to the product without getting help in the forum.

Hi @eekboom

We often do peridoic changes to the docs usually around the time the Camunda engine is released. So that probably explains why this is still not updated.
I’ve let the product team know and they’ll look into get that updated sooner. Sorry about the confusion.

1 Like