Cannot start camuda modeler - no error


I downloaded the open source camunda modeler and tried to run it :

version 4.8.1

Neither the 32 bits not the 64bits version is working.
I checked the log file, I don’t have any error.
I’m under win7 with 8 gigs of mem.
I can see this when starting from command line:

INFO app:main:bootstrap starting Camunda Modeler v4.8.1
INFO app:cli parsing [ ‘Z:\APPS\CamundaBPM2\Camunda Modeler.exe’ ] in ‘Z:\APPS\CamundaBPM2’
INFO app:flags searching for flags.json in paths [
INFO app:flags found []
INFO app:flags active {}
INFO app:error-tracking Cannot initialize Sentry: Crash reports not enabled.
INFO app:plugins searching for plugins/*/index.js in paths [
INFO app:plugins found plug-in entries []
INFO app:plugins registered []
INFO app:main:bootstrap received ready

I can see some camunda processes when running the task manager.
It’s apparently working for another colleague, but version is maybe different.

Does it have specific requirements ?


UPDATE: I tried to install it on my personal computer (also win7), and it’s working fine.