Can't see the tutorial workflow in Operate GUI

Just started Zeebe learning a couple of days ago. I follow to “Getting Started” guide as strict as I can. So currently I try to deploy a workflow tutorial model (order-process.bpmn) to
working broker. My OS is Windows 8.1 (java 11.0.5) and I’ve started Elastic Search 6.8, Zeebe Broker 0.22.2, Camunda Operate 1.2.1 one by one. It seems no errors, all components were started fine. Then I 've deployed the workflow by using windows cmd.

zbctl.exe --insecure deploy …/order-process.bpmn

Response looks good enough:

D:\Zeebe\Zeebe\zeebe-broker-0.22.2\bin>zbctl.exe --insecure deploy …/order-proc
“key”: 2251799813685250,
“workflows”: [
“bpmnProcessId”: “order-process”,
“version”: 1,
“workflowKey”: 2251799813685249,
“resourceName”: “…/order-process.bpmn”

But I see nothing in Operate GUI (localhost:8080 demo/demo). Probably I could not enable the Zeebe Elasticsearch exporter correctly. But I have added getting-started.yaml file inside \zeebe-broker-0.22.2\conf directory and started my broker with the key


What I see in log file (broker) is that tag ‘exporters’ is empty /… “exporters”: [] …/ so I don’t know whether is good or not.

So please help!
Thanks and regards,

Correct. The exporter is not loaded.

Use the latest 0.23.0-alpha. 0.22 uses the legacy toml format for config. See here:

For an old-school toml file, see here:

Hi Josh Wulf,

Thanks for your reply! I’ve downloaded zeebe-broker-0.23.0-alpha2 and camunda-operate-0.23.0-alpha2 correspondingly. And now it worked out.

Thank you once again.


Can you tell me how you configured it. Where is the configuration file and how to start it.
I also downloaded the latest version. But exporters are still empty.

Hello wenminglei,

If you get the right distributions (elasticsearch, zeebe broker, camunda operate). Then pls do the next steps. The notes below are appropriate for Windows.

  1. Prepare getting-started.yaml as it is described at tutorial Try to follow “yaml” notation strictly, avoid TABs etc. Put this file to:

  2. start ElasticSearch first. It looks like this :
    cd \elasticsearch-6.8.0\bin

  3. Start Zeebe Broker as it described at tutorial with passing getting-started.yaml as a parameter.
    cd Zeebe\Zeebe\zeebe-broker-0.23.0-alpha2
    bin\broker.bat --spring.config.location=file:./config/getting-started.yaml

Double check that “getting-started.yaml” is available in a path you have specified.

  1. Look at Zeebe Broker terminal output and make sure that exporter is opened.

    “exporters”: {
    “elasticsearch”: {
    “className”: “io.zeebe.exporter.ElasticsearchExporter”
    “gateway”: {

    2020-04-14 12:43:56.762 [Broker-0-Exporter-1] [Broker-0-zb-fs-workers-0] INFO i - Exporter opened
1 Like

Hi, Andrey,
Thank you very much for your reply!
I tried for two days, and today I finally succeeded!
Thank you once again.

1 Like