CMMN diagram does not open: error "not yet drawn"

Yesterday I created my first CMMN diagram: 4 caseplanmodels, containing Eventlisteners, Tasks and Expanded stages (some of which are as of yet empty). When I tried to open it today, I got the following error. What is happening and how can I fix this? Please keep in mind that I am not experienced with XML or code. I just want to continue work on my graphical model, that I need in about 3 hours from now.

[C:\Camunda\techdocs\Delta Uitdienst datum vullen.cmmn] element <cmmn:PlanItem id="PlanItem_1ikm9wo" /> referenced by <cmmn:PlanItemOnPart id="PlanItemOnPart_1hhst1u" />#sourceRef not yet drawn
    at u (webpack:///node_modules/cmmn-js/lib/import/CmmnImporter.js:31:0)
    at notYetDrawn (webpack:///node_modules/cmmn-js/lib/import/CmmnImporter.js:242:0)
    at _getEnd (webpack:///node_modules/cmmn-js/lib/import/CmmnImporter.js:203:0)
    at _getSource (webpack:///node_modules/cmmn-js/lib/import/CmmnImporter.js:107:0)
    at add (webpack:///node_modules/cmmn-js/lib/import/Importer.js:39:0)
    at element (webpack:///node_modules/cmmn-js/lib/import/CmmnTreeWalker.js:67:0)
    at file:///C:/Camunda/resources/app.asar/public/5.5.js:1:51305
    at file:///C:/Camunda/resources/app.asar/public/5.5.js:1:52967
    at iterator (webpack:///node_modules/min-dash/dist/index.esm.js:166:0)
    at file:///C:/Camunda/resources/app.asar/public/5.5.js:1:52951 [ error ]

I think the following is the relevant XML code:

<?xml version="1.0" encoding="UTF-8"?>
<cmmn:definitions xmlns:dc="" xmlns:cmmndi="" xmlns:cmmn="" xmlns:xsi="" xmlns:di="" id="Definitions_0g07dqu" targetNamespace="" exporter="Camunda Modeler" exporterVersion="3.0.1">
  <cmmn:caseFileItemDefinition id="CaseFileItemDefinition_0zc1ypn" name="TWK" />
  <cmmn:caseFileItemDefinition id="CaseFileItemDefinition_1se9rev" name="TWK2" />
  <cmmn:caseFileItemDefinition id="CaseFileItemDefinition_03103va" name="TWK" />
  <cmmn:caseFileItemDefinition id="CaseFileItemDefinition_05ce4bk" name="TWK" />
  <cmmn:case id="Case_1bakshp">
    <cmmn:casePlanModel id="CasePlanModel_1jtouv4" name="Case Uitdienst ongedaan maken">
      <cmmn:planItem id="PlanItem_00nedtg" definitionRef="Task_05f4thi">
        <cmmn:entryCriterion id="EntryCriterion_03n9em8" sentryRef="Sentry_1riflyz" />
      <cmmn:planItem id="PlanItem_1ikm9wo" definitionRef="EventListener_1wbns1f" />
      <cmmn:planItem id="PlanItem_1p8ydj2" definitionRef="Task_1vq2r0y">
        <cmmn:entryCriterion id="EntryCriterion_144cbvz" sentryRef="Sentry_02c70js" />
      <cmmn:planItem id="PlanItem_0oe8j0s" definitionRef="Task_0mko8gd">
        <cmmn:entryCriterion id="EntryCriterion_1duybal" sentryRef="Sentry_0l3uovo" />
      <cmmn:planItem id="PlanItem_0p8g6yk" definitionRef="Stage_00koyl6" />
      <cmmn:sentry id="Sentry_1riflyz">
        <cmmn:planItemOnPart id="PlanItemOnPart_1hhst1u" name="" sourceRef="PlanItem_1ikm9wo">

Can you upload the full CMMN file?

Uhm, how and where? I don’t see an upload button or the like in this thread.


Delta Uitdienst datum vullen.cmmn (31.6 KB)

Right. Sorry. Will remove previous reply.

How did you come across this issue? Did you model the diagram using the Camunda Modeler and then tried to re-open it in the Camunda Modeler? Did you use any other modeling tools inbetween?

Yes, I modelled the diagram using the Camunda Modeler, saved it CTRL S, went home and then tried to re-open it in the Camunda Modeler the next day. No other tools inbetween.

This looks like a bug. Can you please open an issue in the respective project?

1 Like

I’m not a developer, just a simple user. I have no acces to or knowledge of Github.
I have given up on Camunda and moved on to a tool that actually works for me, thanks.

Last question before we loose you to that other tool: Is the other tool able to open the diagram you modeled (without throwing an error)?

Well, I’ve taken a different approach, and rebuilt the logic as a workflow. Not ideal but workable nonetheless.

I hadn’t, but now I’ve tried with online trial CMMN, same error. So unless this is the same engine, the data has somehow been corrupted from last save and first subsequent open.

Thanks for your clarification and good luck on with your future endeavors.

Thank you all for the support offered.

In my case, the solution was to remove the extra CasePlanModel. Apparently, CMMN can’t display multiple at once. I hope this helps someone. Thanks for your attention!

1 Like


i have the same problem opening my cmmn-model. :frowning:

AE Vorgehensmodell.cmmn (68.4 KB)