Corrupt schema returned using /process-definition

I am deploying using the diagram designer, the XML looks great when save it. When I pull XML using: /engine-rest/process-definition/

I get broken XML. I am using these IDs for a report, and it was very apparent.

I am using the latest version, It does not happen in an older version.



Release Date:

Nov 30, 2019

Hi - can you attach the broken XML file and describe what is exactly broken, please?

Hi Dirk.

Thanks for the reply.

It is turning out to be an axios/Javscript issue I believe because it works in Postman without corruption (as well as my other system).
Maybe an escaped character is throwing it off. The XML parser does not return the whole set of fields when queried for usertasks .
I will check headers and everything else. Testing between win/linux so something could be amiss. I will post the outcome if anything significant.

I wish I could explain it but axios/xhttprequest was removing a chunk of xml.
I even tried intercepting it, loading as a stream, not working.

The solution was to call it thru my middleware server and return it back. Used the exact same Axios call, worked fine.
I am proxying because of cors, maybe something going on there.

Thanks for your feedback - I am glad it works fine!

Not a Camunda or JDK issue (but could certainly look like one), but just if anyone else sees this(since node/axios is quite popular with frameworks and APIs).

Updating Node to 12.X solved all these problems. The older version has bugs in their proxy server.
Ubuntu uses an LTS version of node with these issues.