Could not resolve dependencies for project

Hello All , I am trying to upgrade camunda version from 7.14.0 to 7.14.16-ee …I Could not find the artifacts for 7.1.416 in public camunda artifactory.Hence , I have updated my POM.xml with private jfrog artifactory end points also added right credentials in settings.xml . But , when i try building the project , I see below error . Has anyone observed same ? Am I missing something? Please share your inputs on this , Thankyou…

Failed to execute :war:0.0.36-SNAPSHOT: Failed to collect dependencies at org.camunda.bpm:camunda-engine:jar:7.14.16-ee: Failed to read artifact descriptor for org.camunda.bpm:camunda-engine:jar:7.14.16-ee: Could not transfer artifact org.camunda.bpm:camunda-engine:pom:7.14.16-ee from/to camunda-bpm-nexus-ee (JFrog): PKIX path building failed: unable to find valid certification path to requested target → [Help 1]

I also tried by adding the certificate from jfrog private artifactory to my JDK truststore .Even then I see the same error as above. Do you think if this has something to with Network restriction or any firewall rules to be added for the private artifactory endpoint?

Can you show what exactly what your POM looks likes?