Default Ids not working in the cockpit on a spring boot project

I am using a project generated by the Camunda Platform Initializr for spring boot.
When I try to log in the cockpit with the id : “demo”, and the password : “demo”, I get an error.
I checked my application.yaml file, which contains the following :

spring.datasource.url: jdbc:h2:file:./camunda-h2-database

id: demo
password: demo

I have already tried deleting and starting the app again.
I think it might be because I selected the security spring boot module when I generated the project in the initializr, but I don’t really know how it affects my project.

Hope someone can help, thanks in advance !

Can you give details about the error you’re having?

It’s the red error message on the login page that says something like “incorrect ids” I don’t know the exact message in english since it is translated in french on my browser.

Can you show a screen shot?


Ok, so the problem is that it looks like you’ve added spring security to your project.
This is in front of the Camunda WebApps and the camunda login only works after you’ve gotten past this.

You could remove it if you don’t need it or you could find the spring security login details

Okay, I found this line in the console when launching the app :

Using generated security password:

I am guessing this is password I need to put here, but I don’t know what to put as a username.
I don’t think I will really need this however, do you know how to disable it ?
Thanks a lot for the help by the way! :slight_smile:

You should be able to just remove the spring security dependency from the bom file.
You could also re-genereate the project from scratch without ticking the “Security” box on

Okay It works now that I commented the security module in the pom.xml :


Thank you again for your help, have a nice day

1 Like