Defining resourceRootPath in process.xml for spring boot application

I’m trying to specify a process-archive in the process.xml with a specific resourceRootPath. This works correctly when running from intellij, but when the boot jar is built and run with java -jar it fails.

The process.xml is as follows

<process-application xmlns="">
  <process-archive name="PowerOfAttorney">
      <property name="resourceRootPath">deployment/powerOfAttorney</property>

and the resource folder is structured as


Using the above I get the following

ENGINE-08024 Found processes.xml file at jar:file:/Workspace/workflow/build/libs/workflow-1.0-SNAPSHOT.jar!/BOOT-INF/classes!/META-INF/processes.xml
ENGINE-08021 Not creating a deployment for process archive 'null': no resources provided.

Does anyone know how the resourceRootPath should be specified so that it works both in a built spring boot jar and via intellij?



As per your project structure it should be like below:

<process-archive name="PowerOfAttorney">
	<property name="resourceRootPath">classpath:deployment/powerOfAttorney/</property>
    <property name="isDeleteUponUndeploy">false</property>
    <property name="isScanForProcessDefinitions">true</property>
    <!--property name="additionalResourceSuffixes">groovy,py</property>-->

@aravindhrs Thanks for the reply, unfortunately it hasn’t worked. defining the bpmn as a resource gives this

java.lang.RuntimeException: org.camunda.bpm.engine.ProcessEngineException: ENGINE-08043 Exception while performing 'Deployment of Process Application null' => 'Deployment of process archive 'PowerOfAttorney': ENGINE-09011 Exception while reading bpmn/PowerOfAttorney.bpmn as input stream: null

but ideally I don’t want to be listing all bpmn files as that should be taken care of by the resourceRootPath.
Without the resource and adding the classpath: in the root path gives the same result as before.

Hi matt,

Did you get this issue resolved?
I am facing the same