Deploy-changes-only not working

I’m trying to create SpringBoot app with camunda. I have file dmn_test.dmn in resource folder, it deploing during start application. Then i upload new version of dmn using java api. Works fine, but then i am sending the same file again(without changes) and camunda adds a new version of file, but its the same as previous

I would like to redeploy it again but only if file differs of already deployed. I tryed to do it by java code:

@Configuration
public class CamundaConfig extends AbstractCamundaConfiguration {

    @Override
    public void preInit(SpringProcessEngineConfiguration springProcessEngineConfiguration) {
        springProcessEngineConfiguration.setDeployChangedOnly(true);
    }
}

Or property deploy-changes-only in application.yaml:
1
Cannot resolve configuration property

Its doing nothing. What am i doing wrong?

Hi @vytsalo
What if you try to rename it to “isDeployChangedOnly” as stated in the documentation Process Archive Configuration | docs.camunda.org ?

Hope it helps.

Hi. its for processes.xml, isn’t? not for application.yaml

You can try the following for the application.yml

camunda:
  bpm:
    generic-properties:
      properties:
        deployChangedOnly: true

tryed. Don’t working for me

Hi @vytsalo,

if you have your SpringBootApplication annotated with @EnabledProcessApplication, you have to add the configuration into the processes.xml.

It’s usually empty, but you can configure your process application here, if you have the annotation.

Hope this helps, Ingo

No, i don’t have @EnabledProcessApplication. I just use default camunda-spring-boot-started configuration. My dmn located in resources deployed automatically

I encounter this same issue of deploy-changed-only not working. I have tried all of these suggestions and nothing has worked. I am using a very vanilla docker deployment of BPM run (camunda/camunda-bpm-platform:run-7.17.0)