Deployment Error When Attaching Two Camunda-Forms

Hello there, I am having issue deploying a process to Camunda engine. Please see my process below. I have one camunda-form for the first user task and I have another form for the second user task. However when I deploy them, I get the following error:
"The deployment contains definitions with the the sane key ’ ’ (id attribute). this is not allowed [deploy-error] "
I read on this forum and some folks mentioned that it might be that I do have multiple bpmn processes with the same “id” and in fact I do not. I created this bpmn as fresh brand new.
I do not see any error in deployment when I only attach one camunda-form to the process. I am not sure why I am facing this issue. I am not a JAVA developer but I used Python for External Tasks.
I appreciate any suggestion to resolve this issue.

Here the forms:

Hey @mocgi ,

could you please share the bpmn and form files and not just the pictures? This way it is easier to debug and see where the error comes from.

Kind regards

Hi @Nele ,
Thanks for your response. Here you are the files.ICP_GW_Workflow.bpmn (4.3 KB)
ICP_form.form (2.7 KB)
feedbak_loop_confirm.form (329 Bytes)

Please note that I had an old bpmn with the same process earlier and then I created this new bpmn but used the same forms. I can also uninstall camunda server and reinstall if this will delete old tables from the server if necessary. Thanks again,

@mocgi ,

the problem is how you attach the forms:

If it is a Camunda Form you can select the Type : “Camunda Form” in the properties panel. Then you can link your form by referring the ID of the form.

Be aware that it is not the file name of the form but the field you set in the properties panel for the form. I would recommend that you change the generated ID to something readable that corresponds to the usage of the form.

I hope that helps

@Nele , thanks for your time,
The problem is that I do not see the same screen as you see when I click on the “user task”. Please see below:

Also, when I open the form I do not see where the “id” is. I see the “Text Fields”. Please see below:
I am on Linux system.

Then I do not understand why it is working for a single form and when I attach 2 forms, it fails.

Hey @mocgi ,

You are using an older version of the Camunda Modeler that’s why your UI does not look like mine. In your version of the Modeler your refer the form correctly.

You can find the General Id of the whole form if you ensure that you don’t have any text field selected.

I think your second form is broken. I don’t see why at the moment. I checked the Json and it looks good to me. But in general there is no problem with attaching multiple forms. I rebuilt the form and attached it and now both are working. You can try to use my rebuilt form and let me know if that works for you test.form (454 Bytes)


1 Like

@Nele is correct. You are using an older version of the form but the reason it is not deploying is because you spelled the form name wrong and they are not matching. You are referencing feedback_loop_confirm.form in the BPMN while the actual name of the form is feedbak_loop_confirm.form . You have feedback spelled as feedbak instead.


Hey @kamaljot ,

really good spotted! I did not see it. I tried it now with the changed name and it works.


1 Like

Hi @Nele and @kamaljot ,
Thanks for your time,
Unfortunately I still have the same issue when I attach two forms at the same time.
I am attaching both the BPMN and the forms. I double checked the form names and they are exactly matching. Where things are wrong. I am not sure?
Let me quickly explain- I initially made this BPMN and then created two forms and then deployed successfully and it worked fine. Then one hour after it , I realized that I needed to change something in the forms such as variables names. Once I changed the form variables and then saved the change. I did go and deleted the deployment on the server and I was trying to redeploy the process with the updated forms, etc but I faced the Deployment error as explained above.
One try was to recreate the BPMN with another name and deploy it and this effort also failed.
I am guessing there is something from last deployment in the server to prevent this but I am not sure.
Is there anyway we delete completely everything from previous deployments on the server?
Thank you for your time,

I am getting an error on deploying these 4 forms
Error:‘The deployment contains definitions with the same key ‘Form_6b8bcf76-e7e9-461c-af34-133ebdfd628d’ (id attribute), this is not allowed [ deploy-error ]’
If I deploy a single form it is deployed successfully but on tasklist page it gives form failure

This is the form
Availability_Form.form (4.7 KB)
p.s I am a new user so I can only add 2 links

Hi @Maha1,
it would be better to open a new thread for your problem.
Here are some hints:

  • Check the IDs of your forms (in the properties panel on the right). They must not be the same. If you created one form as a copy of another, they may have an equal ID.
  • If you choose deployment as the binding option (configuration of user task), the process and the forms must be part of the same deployment. It seems that’s not the case. So change the binding to latest.