Eclipse org/camunda/bpm/dmn/feel/impl/juel/FeelEngineFactoryImpl


I receive the error below in case if I run in Eclipse a Maven → Install.

Any idea how to solve.

Many thank’s for any support.


Running com.camunda.demo.SimpleDemo.InMemoryH2Test
11:34:29.188 [main] DEBUG org.camunda.bpm.engine.test - ==== BUILDING PROCESS ENGINE ========================================================================
11:34:29.318 [main] INFO o.s.b.f.xml.XmlBeanDefinitionReader - Loading XML bean definitions from class path resource [camunda.cfg.xml]
11:34:30.201 [main] INFO org.camunda.bpm.engine.cfg - ENGINE-12003 Plugin ‘SpinProcessEnginePlugin’ activated on process engine ‘default’
11:34:30.214 [main] INFO org.camunda.spin - SPIN-01010 Discovered Spin data format provider: org.camunda.spin.impl.json.jackson.format.JacksonJsonDataFormatProvider[name = application/json]
11:34:30.411 [main] INFO org.camunda.spin - SPIN-01010 Discovered Spin data format provider: org.camunda.spin.impl.xml.dom.format.DomXmlDataFormatProvider[name = application/xml]
11:34:30.421 [main] INFO org.camunda.spin - SPIN-01009 Discovered Spin data format: org.camunda.spin.impl.xml.dom.format.DomXmlDataFormat[name = application/xml]
11:34:30.422 [main] INFO org.camunda.spin - SPIN-01009 Discovered Spin data format: org.camunda.spin.impl.json.jackson.format.JacksonJsonDataFormat[name = application/json]
Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 1.748 sec <<< FAILURE!
com.camunda.demo.SimpleDemo.InMemoryH2Test Time elapsed: 1.748 sec <<< ERROR!
java.lang.NoClassDefFoundError: org/camunda/bpm/dmn/feel/impl/juel/FeelEngineFactoryImpl
at org.camunda.bpm.dmn.engine.impl.DefaultDmnEngineConfiguration.initFeelEngine(DefaultDm


Which project are you trying to install?

Best regards,

Hello Yana,

I try to install the application as shown at given link below in Eclipse Oxygen - Camunda 7.8.0 on Linux calling Maven -> Install - I get the error as described below.

I tried with Eclipse Oxygen - Camunda 7.8.0 on Windows - which is running without compile errors.

Camunda Java example

Best regards,

Hello Werner,

Could you please upload your project so I could try it locally.
I guess you have some problem with the dependencies.

Best regards,

Hi Yana,

see file attachement below - change extension “.txt” to “.zip”, I was not able to upload files with zip-extensions.

SimpleDemo.txt (38.7 KB)

If you succeed, please try to run it in Camunda Server 7.8.0 Tomcat -
I can start the process but the instance terminates not properly.

Checking the process instances gives me the error message below:

Change overriding job priority
Error :
This process definition has no job definitions associated with. The job priority cannot be overridden.

Best regard’s

Hi Werner,

I checked the project and I am a little bit confused.
There is no need of any additional libraries. I removed them from the build path and it is working fine without them.
After that I saw an error in your CheckWeatherDelegate:

	VariableScope execution;

	public void execute(DelegateExecution arg0) throws Exception {
		// TODO Auto-generated method stub

		Random rando = new Random();
		execution.setVariable( "name", "Niall");
		execution.setVariable("weatherOk", rando.nextBoolean());

You don’t need this execution field, you should remove it and use arg0 parameter. Otherwise it throws NullPointerException because execution is not initialized anywhere.
I saw another problem in the bpmn file, the expressions should contain curly brackets (#{weatherOk} and #{not weatherOk}) instead of round ones.

Because of the build problems, I would suggest you to start from scratch and create the project again. Another option is to remove what you’ve added to the build path and try again.

Best regards,