Embedded Form Not Found in Deployment

I am trying to deploy an embedded form but it doesn’t work. I am using the Tomcat 7.12 embedded engine. For a test case scenario I tried the example files referenced here https://medium.com/@stephenrussett/deploying-embedded-forms-with-camunda-rest-api-84cf8010f8c1 but I get Form failure: The form with the resource name ‘sampleEmbeddedForm.html’ cannot be found in deployment.

My form key in the Modeler is embedded:deployment:

Can you provide some additional details? What doesn’t work? The tutorial you linked to is pretty detailed.

It would be helpful if you attached examples of the BPMN and HTML files along with the requests you’re using to deploy the assets.

The embedded form doesn’t display in the tasklist and I get the error Form failure: The form with the resource name ‘sampleEmbeddedForm.html’ cannot be found in deployment. I am deploying through the modeler with the endpoint http://localhost:8080/engine-rest/deployment/create. The embedded HTML form is located in the same folder that the bpmn file is. Does the HTML file need to be handed placed somewhere within the TomCat structure manually? I tried placing it many places but still doesn’t work. I am using the Camunda-bpm-tomcat-7.12.0 version. My BPMN file and the HTML file is attached. The attached example is just a simple example. I had to change the extension on the HTML file to .txt since HTML files cannot be uploaded to the forum.

Thanks,

EmbeddedFormExample.bpmn (2.9 KB)

sampleEmbeddedForm.txt (456 Bytes)

As far as I know the modeler only deploys the BPMN file, as it doesn’t include a way of specifying which forms to deploy.

Instructions on how to deploy via the REST API are laid out in the link you provided. Alternatively, you can include the forms as resources in Tomcat, but you will have to update your form key to be embedded:app: instead of embedded:deployment:. These docs should also be helpful.

Thanks! If I change and use embedded:app: where do I put the html file in the TomCat structure? I tried putting it in both the webapps\camunda and the webapps\camunda\app folders and get the below error in the tasklist.

Form failure: The context path is either empty or not defined.

I understand now. I thought there was a way to put the html file manually within a folder on the TomCat sever for the bpmn model that was deployed through the modeler.

Thanks for your help!!

1 Like

Hi @withnoe,

what do you do after finally ? How do you solve your problem ? I’m exactly at the same stage than you.

Thank you for your help.