Error when including embedded forms


I am trying to work with external forms but I cannot invoke them, it generates the following error:

Form failure: Request has been terminated Possible causes: the network is offline, Origin is not allowed by Access-Control-Allow-Origin, the page is being unloaded, etc.

I have already been looking in the forum for possible solutions that have been recommended but so far none have worked for me, please help me.

I have already searched everywhere but none has worked for me. I have already added the CORS filter to Tomcat’s web.xml configuration file, it still hasn’t worked (
I am using apache-tomcat-9.0.33).

These are some URL’s in which it guides me:

I appreciate someone who can help me, I repeat again and guided me in the official documentation of Camunda and even so I have not solved it.

I attach images of what I am describing.



I wouldn’t expect CORS to play any part here. You’re serving the forms from the same place as the webapp. From your second to last screenshot, it looks like your forms are in the wrong spot. I would expect to see them up in src/main/resources in a folder called forms (at the same level as META-INF). If you look inside the directory structure of Tomcat once your process app is deployed, where are they? (e.g. in ...camunda-bpm-tomcat-7.13.0\server\apache-tomcat-9.0.33\webapps\...)