Error while submitting task form, cannot invoke String.trim()

I am getting the following error when I started a process in Camunda Tasklist.

I implemented it as Camunda-Springboot project.
In the Eclipse IDE Console window, I’m getting errors like this.

Please solve this issue.

Can you upload your BPMN Model?

process.bpmn (7.0 KB)

This is the model

I uploaded bpmn model, what happened @Niall ? Is anything went wrong in model?

can you also show the code for the reserveSeatOnBoatclass - the model seems ok

This is the code of ReserveSeatOnBoat class in java

What version of Java are you using?

I’m using Java 11

Well based on the error i can see that the problem is with line 18 of your code.
I was able to run it without any problems locally - so unfortunately I’m not sure exactly what you could be doing that might cause the error.

Thanks @Niall the problem is solved.

How did you solve the problem?

On line 17,
money = (String) execution.getVariable(money);

I missed the double quotes around the variable money

Finally I refactored & corrected to the below expression
money = (String) execution.getVariable(“money”);

It worked out.


Awww - i see that now :slight_smile:
Thanks for letting me know.