Form not showing up in camunda

Hey all so I’m doing the camunda platform 7 tutorials on youtube and I’ve made the project and the flow and some forms and then imported the code into spring tool suite and run it but when I start the process in camunda it’s not showing the forms, it just says form error. In the camunda modeler I’ve put the settings for the forms as the type is camunda forms, the form reference is preparefordeparture which is the name of the form and binding as latest. I also tried to put the reference as camunda-forms:preparefordeparture.form but that didn’t work either so what should I do to make it work??

Hi @cherlloydfan,

Can you post the process model and the parts of the source code where you reference the forms so that we can get a better idea of what’s going wrong?


Here is the form.

This is what I’ve put in the form settings.

Here is where I’ve saved the forms, in the forms folder in the resources static folders. But I can’t open the form either so what is wrong with it? How can I fix this problem?

Here is the error in camunda, the form should show up here.
So what can I do about this?

instead of adding the path of the file you can add the forum id

i tried it but it doesn’t work. form id and reference key are the same but in the tasklist there is the Form failure message. What am I doing wrong?

Hi @Tee0Paw,

Below post might be of help to you

1 Like

yes that helped! :slight_smile: Thank you. It’s a bit confusing that you add a camunda form via “embedded or external task form”