Getting error like Form Failure for camunda forms in the modeler

I am getting the error as the form failure in the tasklist. I have created an application from and designed the simple camunda form in the modeler. Integrated the forms with a task where formRef as the “form-name” and selecting binding as deployment. When I start the spring boot application and run the task in the tasklist, facing the error of form failure. Kindly help on this?

Please post both your .form file and your .bpmn file.
Usually this error is a result of the reference in the .bpmn file not matching your form identifier.

Please also identify the version of Camunda and Modeller that you are using. Different versions have different ways of linking the .bpmn to the .form (early versions used the form name, later versions use form-id)

The form name is “bookMovieTicket” and bpmn file name is “process.bpmn”.
The version for Modeler is 4.12…0 and for camunda is 7.16.0.

It is important that when asked to post the files, you post the actual files, not screenshots.
With Camunda 7.16, I believe you must use the form ID not the form name.

process.bpmn (3.9 KB)
bookMovieTicket.form (1.1 KB)

Tried with form ID as well, but did not work out. I have attached the .form and .bpmn files as well.

When you deployed your BPMN file to the server, did you also deploy the .form file?

Your formRef matches between the files, and you’ve told Camunda to use a deployed form, which are good configurations.

1 Like

The .form file was also deployed alongside to .bpmn file to the server.
Yayy, it worked after making configured with formId instead of formName.

Thank you for the support.