Help about integrating DMN to a BPMN collaboration Diagram


I’m trying to integrate a DMN in a collaboration diagram BPMN. When I run the process in the Camunda platform 7, I have an error

An error happened while submitting the task form :
Cannot submit task form e10dddab-2adb-11ed-be8f-74782729eca5: ENGINE-02004 No outgoing sequence flow for the element with id 'Gateway_088mdoi' could be selected for continuing the process.

Below the screenshot of the BPMN

Could you explain me where my configuration is wrong?


On the conditional flows for Mail to A, Mail to B, and Mail to C, none of the flows were accepted.

Posting the actual BPMN file is usually a better way to get clear answers (even if it’s a simplified reproduction example that doesn’t contain any confidential information).

Try adding an additional flow from the Exclusive Gateway (for example back to “Save Operation”), but set the “default flow” option on it. It will be selected if no other flow is valid. Setting a default flow is a good practice. You can think of it as an “else” block.

If Var1='Go to A' then
   Do Something
else if Var1='Go to B' then
   Do SomethingElse
else if Var1='Go to C' then
   Do ThisOtherThing
***  Adding a default flow adds this part!
   Log YouShouldNotGetHere

Hi GotnGuts,

Thanks for your reply. I update my BPMN as you suggested to me and It solved the error.
test_bpmn_dmn.bpmn (13.6 KB)
test_decision_1.dmn (2.2 KB)

When I executed the process, It only redirect to default flow even If I choose another flow. For example I load the decision to move to the task PLAN OPERATION, but It returns to the defaut flow SAVE OPERATION.

The output of the decision is set to the variable output and I configure the flow with these expressions ${output == "mail_to_a"}, ${output == "mail_to_b"}, ${output == "mail_to_c"} for any flow. It seems like the variable output is not processed.

How can I make this variable processed?
Thanks for your help

In your DMN, your output is a string “mail to a”, but in your BPMN, you’re looking for a string “mail_to_a”

Since the strings don’t match, they won’t go where you’re trying to send them
You’ve basically got:

set Var1='mail to a'
If Var1='Go_to_A' then
   Do Something
else if Var1='Go_to_B' then
   Do SomethingElse
else if Var1='Go_to_C' then
   Do ThisOtherThing
   Log YouShouldNotGetHere

Which is why you’re getting the YouShouldNotGetHere …

Hi @GotnOGuts,

Thanks so much. It solved that issue.

I have another question about the execution in Camunda.

For example, when I execute the task SAVE OPERATION and use the output mail to b , the redirection is done well to ANALYSE BDE. If I continue the execution, It moved well to SAVE OPERATION. At this step, It could not moved anyway and stay at SAVE OPERATION

Are there any explication why this walk at the first iteration and none to another.

Thanks for your help

If it solved your issue, please remember to mark a post as the solution.

I can’t actually understand what you’re trying to express in your additional question. But do try to keep threads to their topic. If you have a new question, you can always start another thread. Keeping threads on topic help others find the answers to their questions.

1 Like

Hi @GotnOGuts,

Thanks so much for your help.