History Cleanup not removing history


I’m currently trying to get history cleanup running and as far as I can tell its set up and runs but isn’t removing any history.
I have setup the config as follows

        historyCleanupStrategy: endTimeBased
        historyCleanupBatchWindowStartTime: "00:01"
        historyCleanupBatchWindowEndTime: "23:59"
        historyTimeToLive: P1D

In act_hi_actinst I have data from 10 days ago which I would expect to be cleaned up and new processes are getting the removal_time_ populated now which I assume means the config has been picked up.

Using the endTimeBased strategy I believe this will still clean up the old history without the removal_time_ populated.

Is there anything else I need to do or can check to see why its not deleting the history?


Do have set the history time to live flag in your models?

you can easily set this in the camunda modeler in the bottom right of the model “Properties Panel”

You can also set this in the Camunda Cockpit after the deployment.

No I haven’t set it in the individual models, but have provided an engine-wide default (historyTimeToLive: P1D) which should be applied to all processes, and I can see that it is taken into account as all new process instances get a removal_time_ in the db, but existing history from 2 weeks ago isn’t being cleaned up as I would expect with the endTimeBased strategy

Hi @matt, how you solved that issue? I faced the same behaviour.
That is a bit weird as it should work well according to Camunda Docs.