Hooking up Zeebe Simple Monitor to Camunda Cloud

Niall: Is there any way to hook up the<https://github.com/camunda-community-hub/zeebe-simple-monitor| Simple Monitor> to Camunda Cloud?

zell: Nope :smile:

Niall: Hahhaha - thanks anyway Zell :slightly_smiling_face:

Nele: I try to run it with Zeebe, but I have problems with my Docker compose file… are there any hints and tricks how to set it up?

zell: @Nele did you tried these https://github.com/camunda-community-hub/zeebe-docker-compose/tree/master/simple-monitor ?

zell: Simple monitor comes also with a docker compose maybe you can check this as well https://github.com/camunda-community-hub/zeebe-simple-monitor/blob/master/docker/docker-compose.yml

Nele: Nope I ended up here:

I will try the other docker compose file later and let you know how it goes… it is also likely that I oversee something. My docker knowledge is limited

zell: :+1: Feel free to write here. Ideally with the config and error/failure you get :slightly_smiling_face:

Nele: thank you :pray:

Note: This post was generated by Slack Archivist from a conversation in the Zeebe Slack, a source of valuable discussions on Zeebe (get an invite). Someone in the Slack thought this was worth sharing!

If this post answered a question for you, hit the Like button - we use that to assess which posts to put into docs.

Josh Wulf: Simple Monitor needs a Hazelcast exporter. At the moment custom exporters are not supported in Camunda Cloud hosted

Nele: It is running… I feel I should not touch it again… @Thomas Heinrichs helped me with the configuration. That was my solution path.

1.Error message:

The Compose file './docker-compose.yaml' is invalid because:
Unsupported config option for services.postgres: 'profiles'
Unsupported config option for services.simple-monitor-in-memory: 'profiles'
Unsupported config option for services.simple-monitor-postgres: 'profiles'

I deleted the three profiles in the docker-compose.yaml

2. Error message:

Bind for failed: port is already allocated

I deleted the zeebe simple monitor and postgres from the docker-compose.yaml. So there is just zeebe simple monitor in memory left

3. Error message:

Cannot find Hazelcast bean 

<https://github.com/camunda-community-hub/zeebe-hazelcast-exporter/releases|Downloaded the jar of hazelcast with dependencies> manually and put it in the right location.

Is this the right way to go? I would find it helpful to mention somewhere that the jar has to be downloaded for the docker-compose up.

also maybe a comment in the Yaml would be nice about the profiles… should I do a PR?

zell: Cool that it works now :clap: Sounds like a pain :smile: tbh it is quite a while ago that I used it. Maybe @saig0 has an opinion on it when he is back from vacation. Feel free to create an issue or PR. Not sure who really maintains it right now.