How to configure existing Elasticsearch instance with Camunda 8.25 Helm Chart

I am currently deploying Camunda 8.25 with the provided Helm Chart to Kubernetes. In my setup I use an already existing Elasticsearch cluster.Therefore I turned off the creation of an Elasticsearch cluster with the Helm value:

  enabled: false

And configured the URL of the existing Elasticsearch cluster with:

    url: http://my-elasticsearch:9200

But I also would need to set username/password for basic auth to connect with http://my-elasticsearch:9200. However, I cannot find any values in the Helm chart to configure this and Camunda then fails with http code 401 when connecting.

→ How can I configure username/password in the Helm chart for an already existing Elasticsearch instance?

Thanks in advance for any help.

@martin_schaefer - you can set a username/password (and many other options) in the Elasticsearch Exporter configuration. You can read more about it here!

Thank you for that hint. I already came along this but really have no clue where this configuration part should be applied. There is no matching section in values.yaml Have you an example on how to apply this to a deployment with the Helm chart?

@martin_schaefer - I believe they go in the zeebe.brokers section, so something like this:

        className: io.camunda.zeebe.exporter.ElasticsearchExporter
          # the rest of the config
1 Like

Hi @nathan.loding ,
I am doing same in 8.4. I don’t find zeebe.brokers in the values.yml file.
Could you please help on the same

Hi @vinothkumar - have a look at this new guide and see if it helps!