How to enable OpenAPI for Camunda spring-boot?

I have using embedded Camunda with spring boot and below are the details:

Spring-Boot: (v2.2.11.RELEASE)
Camunda BPM: (v7.13.0)
Camunda BPM Spring Boot Starter: (v7.13.0)

How to enable OpenAPI for Camunda 7.13?

Can this be achieved just by adding the camunda-engine-rest-openapi dependency? I have tried that but does not work.

What exactly are you trying to enable? Are you trying to install the swaggerui?

How to get the swaggerui?

I can see that is available in camunda-bpm-run-7.15.0

I want to enable the similar one with Camunda 7.13 Spring boot application

SwaggerUI is itself a component you’d need to add to your spring boot project. Once you’ve added that you can give it Camunda’s OpenAPI documentation.

I haven’t done this myself, but i think @davidgs was playing around with that.
You can also follow a tutorial: Setting Up Swagger 2 with a Spring REST API | Baeldung

Hi @Himanshu_Singh,

here you can find the module that adds swagger-ui to Camunda RUN: camunda-bpm-platform/distro/run/modules/swaggerui at master · camunda/camunda-bpm-platform · GitHub</tit

It may be worth to have a look into the assembly folder, too: camunda-bpm-platform/distro/run/assembly at master · camunda/camunda-bpm-platform · GitHub

Hope this helps, Ingo

Hello @Ingo_Richtsmeier ,

I do have the exact requirement. Tried your suggestions, but the rest endpoints exposed by camunda-rest are not visible in the swagger-ui.
I can see the additional controllers which I manually defined though.

Thanks in advance !

Hello guys,

I can’t enable swaggerui either in my springboot project. BTW I’m using:

Spring-Boot: (v2.4.3)
Camunda Platform: (v7.16.0-alpha4)
Camunda Platform Spring Boot Starter: (v7.16.0-alpha4)

1 Like

Hello @Rogerio_Duarte, @mishrasovan and @Himanshu_Singh,

here is a new example how to use the Camunda OpenApi spec in your spring-boot application: code/snippets/spring-boot-with-swagger at master · camunda-consulting/code · GitHub

Hope this helps, Ingo

1 Like

Please help me fix issue