How to get started with Camunda 7.6.0

Dear friends of Camunda,
I need some very basic help, and I am not a software engineer, neiter am I familiar with programming. This is my first post here, so I hope for your patience with me.
As for now, I “simply” want to try how this whole thing works so I can talk somewhat educatedly to clients. Clients, who are interested in using BPMN diagrams to eventually engage with a programming company which can build what they need.
I was trying to follow the instructions under to set up the environment, but got stuck when it comes to installing Eclipse with the Camunda Modeler. Since 7.4.0, this is not supported anymore, but there is no description how to proceed with the newer versions.
I can install the standalone modeler, but then I do not have Eclipse…?
Is there a “Getting started with 7.6.0 for dummies” somewhere around?


Hi Tobias,

The most basic (and up-to-date) getting started guide would be this one: Feel free to ask if you have any problems with it.


1 Like

Hello Thorben,
thanks so much for the quick & helpful response, and sorry for my late reaction!
FYI, I did get some progress with this guide, but I’m still not there. For now, this little project is paused, I’ll let you know when I get time to continue with it and have more questions.

best regards,

1 Like

Hi. This is my first foray into BPM with Camunda and I’m also - like tobias - having a little problem getting started.

I had planned to start a new thread, but spotted this one. Don’t mean to hijack and apologies if this is not the done thing. Happy to split my query out from this one if that’s preferable.

I’m looking to install on a Windows 10 laptop to familiarise myself with the Camunda product/process. I’ve been following the guide here: to set up, but hit a problem when it came to Project Setup as Eclipse is mentioned and I had thought the Camunda Modeller no longer required this.

So far I have:

  1. Installed JDK.
  2. Camunda BPM Tomcat.
  3. Camunda Modeler.

I’ve been able to model a process within Camunda Modeler and I’m now looking to package this to deploy and run, but not sure what I need to do this. I assume some flavour of Eclipse - Kepler is mentioned in another guide, but this no longer seems to be available.

Could you provide some guidance on the additional components that I need to progress from the Modeler output?


Hi Ian,

You don’t need Eclipse to model a process, however you need Eclipse to build a process application containg that model. In general you can use any Java IDE, but this tutorial uses Eclipse. Just download and install the latest Eclipse release and you should be good to go (could be any Eclipse version that has Maven integration). I think we should mention Eclipse as a requirement in the guide’s introduction and created a ticket for that:


Hi Thorben,

Thanks for the quick response, it is much appreciated. I’ll report back on my progress once I’ve downloaded and installed Eclipse and taken it from there.


I’m going to be the fly in the ointment here.

Camunda and its staff are great people and Camunda itself is generally rock-solid and very fast. However, Camunda assumes you have in depth knowledge of BPMN, Java, Web Services, OSGI, Scripting, etc., etc., etc. In other words, Camunda is more like a development environment and less like a “user oriented” application.

You are going to struggle learning Camunda, be prepared for it. However, the user community is very helpful. Camunda’s are the more responsive to forum questions than anyone else I’ve dealt with. I’m astounded at how quickly they get back to you sometimes.

Running Camunda requires a sophisticated team. If you don’t have Java programmers, system engineers, etc., you’re going have a very hard time doing anything. Camunda’s documentation is primarily a reference manual, not a “how-to” guide. Your best resource for how-to is to Github and check out the Camunda example projects. They have put hundreds of different things in there. But, you will often need to able to read raw code and figure it what it means.

Camunda should look at Talend’s documentation, which is an order of magnitude better. Camunda has a great product, great people, but disappointing documentation.

Don’t hesitate to post often in the forum as you will usually get a quick response.

A quick update to say I’m making progress now that I have Eclipse installed.

I have encountered one odd thing though, regarding the DMN 1.1 Get Started example. The Decision Table in Camunda Modeler looks like this …

In Cockpit, the Season and Dish columns appear to have the values swapped, i.e. values that should be under Season are under Dish and vice versa.

I’ve had a closer look at the modeler and Eclipse content and and don’t see anything obviously incorrect. Is this something that you have seen before?


Can you post up the DMN file that you’re using?

You need to go into “Advanced Mode” on the GUI.

Which browser do you use?

Oh, and one more thing, the Eclipse Plugin will not configure the DMN properly through the property pages. This might not hold true if you’re using Modeler for the BPMN. It just depends.

The problem is the “camunda:decisionRef=” tag doesn’t have a property page entry. So for your example in the Business Rule Task you’d have to have something like this (specifics will vary depending upon what you’re doing):

<bpmn2:businessRuleTask id="myDmn" camunda:decisionRef="dish" camunda:async="true" name="Dish">

I think this might be because they dropped development of the Eclipse plugin around the time they introduced DMN into Camunda. So, you have to put this and other DMN related tags in manually.

This can sometimes cause an error when you return to the diagram. You just need to close (and save) the BPMN file and reopen it. It’s also possible that I’ve missed how this should be done properly in the Eclipse plugin.

It’s a known internet explorer issue. If you use firefox or chrome, everything is fine.

Cheers, Ingo

Please ignore the reply. I did not (as usual) read your post as carefully as I should.

Thanks everyone for the suggestions.

Ingo - I was using IE, have now tried Chrome and it’s all good.

Thanks again,