How to identify the deployment URL for a remote server

Hi -

We/I have had great success following Camunda tutorials on our ‘local’ VDI machines for making and deploying BPMN and DPM (I go from Modeler directly after a java example in Spring Boot IDE).

Can you please @niall socialize the following question for me so I can ‘get my mojo back’:

I am trying to deploy from Camunda Modeler to our staging server (a Centos VDI). Normally this URL endpoint is specified locally on my own VDI during the deploy in the dialog as : http://localhost:8080/engine-rest by default and works fine

Do you have any ideas? I have searched all over (this forum, Camunda docs, web) and tried various things, e.g. : to our staging server (ip masked of course: http://99.999.999.99/camunda/app/ …? is there an impact because we launching from within docker? I was thinking: First step - make sure we can duplicate deployment when on staging localhost… but this is tough because we dont have camunda modeler there, it is unsupported linux distro…

Ideas - pointers to docs/tutorial appreciated

Best Regards,

Hey - I figured it out by trial and error, although a description of why it works this way would be nice, so please if you know where I can get that documentation it would be great.


######### this worked (remote staging Centos server ip masked of course): http://99.999.999.99/engine-rest ← no idea why, just trying permutations and combinations
apparently port and or other ‘hinted at’ portions of the URL endpoint are not required - this is not clearly documented, at least obvious for me, based on my hours of researchNow try a POSTMAN to evaluate that deployed DMN:
instead of POST: localhost:8080/engine-rest/decision-definition/key/JobStepStatus//evaluate
replace it with 99.999.999.99
That worked beautifully: evaluates the body content and returns the expected response

1 Like

If you deploy camunda to a server the rest api is always going to be avaialbe at <serverip:<camundaPort>/engine-rest/ by default.

Thanks Niall - i did not have control over who setup docker, and was assuming that 8080 was the port, but when i put the port in rest endpoint it threw an error in Camunda Modeler. When I took port out, it worked - therefore my confusion. Maybe docker resolves this by default somehow.