How to install Camunda Modeler from source on FreeBSD

Hello, community members!

I’m newbie in Camunda BPM and want to use it on my laptop with FreeBSD 11.0. I’ve installed Node.js and NPM, OpenJDK and another dependences but don’t understand how to build Camunda Modeler. I’ve made uncountable efforts to install Modeler with NPM but without success, sorry for my stupidity)). I tried to use Linux application also but it was a huge amount of Linux libraries that I loaded to force it run but it seems as endless loop))).
Is it possible to build from source and run Camunda Modeler on FreeBSD?
Please provide detailed instruction how I can make it.
I suppose this instruction will be helpful for FreeBSD adherents and will increase Modeler usage.

Thanks in advance!

Hi @Toem,

I assume you have went through the steps here Which steps did you execute exactly and what is the output that you are stuck with?


Hello, Askar!

Sorry for my delay. The problem that I faced now is phantomjs version installed in my system (installed 2.0.0 but 2.1.1 required). There is no FreeBSD binary package in repository with newer version and I tried to build it from source. Building from source stopped with error and I wrote to FreeBSD port maintainers. Therefore I need to wait until they resolve the problem. After that I can continue my efforts and will inform you about results.

Regards, Toem.

for phantomjs issues (LIFECYCLE etc) this option solved the problem for me
npm install --unsafe-perm