How to start a process with multiple swim lanes?

Hey guys,

if have a process with multiple swim lanes. Now I wanted to start the process via a POST request. As in video tutorials I used for that the General ID. In my case: “Forschungsantrag_stellen”

so the POST request for starting the process would look like that:

But then I get:

“type”: “RestException”,
“message”: “No matching process definition with key: Forschungsantrag_stellen and no tenant-id”

I think that is somehow related with the multiple swim lanes of my process.
Which ID do I need to use to start a process with multiple swim lanes?

Attached you can find the .bpmn file of the process.

Thank you very much!

Best wishes,

Forschungsantrag_stellen.bpmn (18.6 KB)

You’re correct - once you add a pool the id you need to use to start it is actually on the pool itself.
To see it just click on the pool (where the label is) instead of the canvas of the model

1 Like

Thanks Niall for your fast reply!

I deployed my process. In deployment is displayed like that:

If I now want to start the process with this POST request:

I still get the error:
“type”: “RestException”,
“message”: “No matching process definition with key: Participant_0xckqt4 and no tenant-id”

I have the feeling that the POST fails because the process ID in the dashboard ist f031e224-06f0-11ea-a2ed-0242ac110002…

Hi @wienchma,

you have to use the Process ID, in your case Process_0vtz178.

Or rename the ID to something meaningful.

Hope this helps, Ingo

1 Like

Thank you both!
The problem is my process. I just tried the followed example process:

I could start it with the Process ID.

Afterwards I changed all tasks of the process “Forschungsantrag_stellen” to User-Tasks, but it still did not work. I think I have to remodel the process and then try it again :slight_smile: