How to start process after deployment?


I created deployment via REST API - deployment/create and got the following response:

Then I tried to start deployed Process using /process-definition/key/Process1/start , however, I got message:
“No matching process definition with key: Process1 and no tenant-id”

I tried to call /process-definition/key/3463b0bb-0407-11e7-acee-c8d3fff2626c/start as well, but with the same result.

Please advice.

Thank you,

1 Like

Hi @igorla,

have tried if the process was really deployed or the key is actually “Process1”? You could verify that by performing a GET request on /process-definition (see here for more information).

Does that help?


1 Like

I ran /process-definition request and I don’t see 2 processes that I deployed via REST, only these processes that loaded from within my project.

Hi Igor,

if possible than please use the latest version of Camunda (7.7.0-alpha1).

In this version we improved the Deployment REST resource. If you run a POST request on the
/deployment/create resource the response contains the successful deployed process definitions. If
the list of process definitions are empty no process definition was deployed.

A reason for this can be that you forgot to set the isExecutable flag to true.

Best regards,

Unfortunately, due to some reasons we may run 7.6 only at that time and I don’t see isExecutable flag there.
However, now I wonder if /deployment/create is right way to deploy new Process?

Hi @igorla,

Yes, it is.

Could you maybe post the response of the create request? Also the body of your request would be helpful to spot the problem.


I posted the response at the beginning of this thread.
The request was sent in multipart-form - 2 parts,

  1. deployment-name=Process1
  2. Uploaded bpmn files

Hi @igorla

sorry, forgot about that. I seems like you are using the name of the deployment to start the process. However, you need to use the id of the process definition as key (I know this is a bit confusing).

Can please post the processes you want to deploy? Then I could verify that and give you an example of how your request should look like.


OK, once I used process id inside bpmn the problem was solved. Yes, it is indeed a little bit confusing with key;)


comp.bpmn (3.2 KB)

I deployed my bpmn (see attachment) and started an instance by calling web service /engine-rest/process-definition/Review_COMP:2:2aa0ba5f-039b-11e7-935e-005056bd024b/start. The web service returned 200 success code.

However, when I go to the Cockpit, there is no instance listed. In the database, a new record is found in the ACT_HI_PROCINST table, but its status is COMPLETED. No new record in the ACT_HI_TASKINST table was created.

Hi tedh,

since your process have no wait states it will be simply executed. It seems to me that you want to use a user task.
Change the task type in the modeler with the help of the small wheel into a user task.


It works. Thanks :slight_smile:

1 Like