Import of BPMN XML did not import all elements

During my first steps in BPMN I created a BPMN with another tool, my colleague tried then to import that in Camunda and in
Only parts of my BPMN got imported, but I have no idea regarding the root cause.
As a developer I know that testing feedback is usually welcome, so I enclose the XML and the graphic, in case anyone would like to have a closer look.
That was my first BPMN, so it still has some bugs. Maybe that was the root cause, but my feeling is also a buggy BPMN should be able to get imported.
(Yes, I have to create more lanes for the roles involved, and there are a lot of other things not yet perfect… :slight_smile: )

Projektabwicklung.bpmn (37.7 KB)

Hi @bernd.korthaus,

import is supporting standard bpmn symbols only as I know. All signavio specific extensions and elements will be ignored. Could you list things that you expect to be imported, but were not included in result?


Hi Askar,
only the lower 20% of that diagram are imported, so most of the tasks which are for sure standard were not. Did you try to import?
You are right, there are many extensions in the xml, although I used only standard elements as far as I know.
But I guess that the bpmn 2.0 would say “Ignore extensions in case they appear”.
However I am not a xml guru, so it could be that extensions can disrupt a proper bpmn xml, making it impossible to interchange the xml. But that would make such a standard at once unusable for interchanging between different systems.

I just tried myself with and imported the xml above, I got the same result as my colleague:

There is also this message that tells, sorry I did not enclose it right away:

So it looks as there is a dead link to a task that is not included in the xml.
I had now a look inside the xml, that task exists there:

task completionQuantity=“1” id=“sid-75511BE5-1825-49D0-9ADA-9F69F320B83A” isForCompensation=“false” name=“Meßplan erstellen” startQuantity=“1”

Hi @bernd.korthaus,

Your bpmn xml contains two processes, a process for Messtechniker and a process that contains the other activities (like Project anlegen etc.). As a consequence, you modeled a collaboration, whereby only the Messtechnicker process is part of the collaboration.

However, bpmn.js does not recognize the second process, since it is not part of the collaboration. As a result, you get the import warnings and only the Messtechniker is drawn.

What you could do is, put the second process also into a participant.

Does it help you?



Hi Bernd,

you have two processes in your bpmn file.
In the Camunda modeler only one process will be shown.
I moved them into one process and the modeler showed me the following process model:

Projektabwicklung.bpmn (37.5 KB)

Please move them into one process.

Best regards,

1 Like

Ok, I got it, thank you all! :slight_smile:

Sorry @roman.smirnov,

didn’t saw that you have already answered :smiley:


Just tried - it’s really snappy! :+1: