Issue With Oracle Database Connectivity

Hi ,
I am new to camunda,
As we all know,
Camunda uses inbuilt h2 database as its database…
I need to use Oracle instead of h2.

I had modified SERVER.xml in conf folder of Apache Tomcat.
But It shows error in catalina.log,

org.apache.catalina.LifecycleException: Failed to start component [StandardServer[8009]]
Caused by: org.camunda.bpm.engine.ProcessEngineException: ENGINE-08043 Exception while performing ‘deploy BPM platform’ => ‘Start process engine default’: ENGINE-03005 Execution of ‘UPDATE EverLivingJobEntity[8e22ba29-8011-11e8-a4f0-f8b15698a8cd]’ failed. Entity was updated by another transaction concurrently.
Caused by: org.camunda.bpm.engine.OptimisticLockingException: ENGINE-03005 Execution of ‘UPDATE EverLivingJobEntity[8e22ba29-8011-11e8-a4f0-f8b15698a8cd]’ failed. Entity was updated by another transaction concurrently.
05-Jul-2018 15:50:51.626 SEVERE [main] org.camunda.commons.logging.BaseLogger.logError ENGINE-08044 Exception while performing ‘Stop managed thread pool’: Cannot stop service org.camunda.bpm.platform:type=executor-service: no such service registered: service is null
05-Jul-2018 15:50:51.699 INFO [main] org.apache.coyote.AbstractProtocol.destroy Destroying ProtocolHandler [“http-nio-8089”]
05-Jul-2018 15:50:51.710 SEVERE [main] org.apache.coyote.AbstractProtocol.destroy Failed to destroy end point associated with ProtocolHandler [“http-nio-8089”]

This is my server.xml,

<?xml version='1.0' encoding='utf-8'?>
<Resource name="jdbc/ProcessEngine"
          maxIdle="20" />

<Resource name="global/camunda-bpm-platform/process-engine/ProcessEngineService!org.camunda.bpm.ProcessEngineService" auth="Container"
          description="camunda BPM platform Process Engine Service"
          factory="org.camunda.bpm.container.impl.jndi.ProcessEngineServiceObjectFactory" />
<Resource name="global/camunda-bpm-platform/process-engine/ProcessApplicationService!org.camunda.bpm.ProcessApplicationService" auth="Container"
          description="camunda BPM platform Process Application Service"
          factory="org.camunda.bpm.container.impl.jndi.ProcessApplicationServiceObjectFactory" />
<!--The connectors can use a shared executor, you can define one or more named thread pools-->
<Executor name="tomcatThreadPool" namePrefix="catalina-exec-"
    maxThreads="150" minSpareThreads="4"/>

<!-- A "Connector" represents an endpoint by which requests are received
     and responses are returned. Documentation at :
     Java HTTP Connector: /docs/config/http.html (blocking & non-blocking)
     Java AJP  Connector: /docs/config/ajp.html
     APR (HTTP/AJP) Connector: /docs/apr.html
     Define a non-SSL HTTP/1.1 Connector on port 8080
<Connector port="8089" protocol="HTTP/1.1"
           redirectPort="8443" />
<!-- A "Connector" using the shared thread pool-->
<Connector executor="tomcatThreadPool"
           port="8080" protocol="HTTP/1.1"
           redirectPort="8443" />
<!-- Define a SSL HTTP/1.1 Connector on port 8443
     This connector uses the JSSE configuration, when using APR, the
     connector should be using the OpenSSL style configuration
     described in the APR documentation -->
<Connector port="8443" protocol="HTTP/1.1" SSLEnabled="true"
           maxThreads="150" scheme="https" secure="true"
           clientAuth="false" sslProtocol="TLS" />

<!-- Define an AJP 1.3 Connector on port 8009 -->
<Connector port="8009" protocol="AJP/1.3" redirectPort="8443" />

<!-- An Engine represents the entry point (within Catalina) that processes
     every request.  The Engine implementation for Tomcat stand alone
     analyzes the HTTP headers included with the request, and passes them
     on to the appropriate Host (virtual host).
     Documentation at /docs/config/engine.html -->

<!-- You should set jvmRoute to support load-balancing via AJP ie :
<Engine name="Catalina" defaultHost="localhost" jvmRoute="jvm1">
<Engine name="Catalina" defaultHost="localhost">

  <!--For clustering, please take a look at documentation at:
      /docs/cluster-howto.html  (simple how to)
      /docs/config/cluster.html (reference documentation) -->
  <Cluster className="org.apache.catalina.ha.tcp.SimpleTcpCluster"/>

  <!-- Use the LockOutRealm to prevent attempts to guess user passwords
       via a brute-force attack -->
  <Realm className="org.apache.catalina.realm.LockOutRealm">
    <!-- This Realm uses the UserDatabase configured in the global JNDI
         resources under the key "UserDatabase".  Any edits
         that are performed against this UserDatabase are immediately
         available for use by the Realm.  -->
    <Realm className="org.apache.catalina.realm.UserDatabaseRealm"

  <Host name="localhost"  appBase="webapps"
        unpackWARs="true" autoDeploy="true">

    <!-- SingleSignOn valve, share authentication between web applications
         Documentation at: /docs/config/valve.html -->
    <Valve className="org.apache.catalina.authenticator.SingleSignOn" />

    <!-- Access log processes all example.
         Documentation at: /docs/config/valve.html
         Note: The pattern used is equivalent to using pattern="common" -->
    <Valve className="org.apache.catalina.valves.AccessLogValve" directory="logs"
           prefix="localhost_access_log" suffix=".txt"
           pattern="%h %l %u %t &quot;%r&quot; %s %b" />


Any Suggestions will be appreciated , Thanks

Which versions of the Oracle database and the JDBC driver do you use?

Thankd for your reply,

Oracle Version -PL/SQL Release - Production
ojdbc driver version -ojdbc6-

See this post:

1 Like

Thank you so much Thorben,

It worked.

You saved my day!

Hi Thorben,
I stucked in one more thing,
Actually I was connected to oracle database , but all tables are empty(no data).
But I need some default data like users,groups … which present in h2 database.
If possible, please give some suggestions

I am running into same issue. I am running Camunda 7.9, Oracle, I am using ojdbc6 and I also added the config parameter in my process.xml as below.
process-archive name=“sampleapp-pa”>
<-property name=“isDeleteUponUndeploy”>false <-/property>
<-property name=“isScanForProcessDefinitions”>true<-/property>
<-property name=“jdbcBatchProcessing”>false<-/property>


But still getting the error Cannot submit task form 628553ee-b50c-11e8-b2ce-0050568d09f4: ENGINE-03005 Execution of ‘DELETE TaskEntity[628553ee-b50c-11e8-b2ce-0050568d09f4]’ failed. Entity was updated by another transaction concurrently.
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(
at sun.reflect.DelegatingMethodAccessorImpl.invoke(
at java.lang.reflect.Method.invoke(

Note that this exception is expected if the same entity is modified by two transactions in parallel. See for details.


Thank you for your response. So what would be the solution for me to get through this error. Right now my application is simple approval request workflow which is same as twitter review sample application. Here after the tweet is approved, I am trying to store it in the database. Right now as soon as I hit the submit after checking the “Approved” flag, its throwing error and not able to proceed further.

Hi @ram_perl,

try to disable the JDBC batch processing:

It doesn’t work for Oracle 11.

Hope this helps, Ingo

Hi Ingo_Richtsmeier, Thank you for the reply. I already did that and still getting same issue.

Any suggestion. I disable the jdbcBatchProcessing parameter inside my processing.xml using the property. Am I doing something wrong or is there any other way of setting it.

Hi @ram_perl,

jdbcBatchProcessing is part of the <process-engine> section:

Where did you place it?

Cheers, Ingo

Here is my processes.xml file under resources/META-INF directory
process-archive name=“sampleapp-pa”>



<-property name=“isDeleteUponUndeploy”>false <-/property>

<-property name=“isScanForProcessDefinitions”>true<-/property>

<-property name=“jdbcBatchProcessing”>false<-/property>


You should add the configuration in the bpm-platform.xml (assuming you use the Tomcat distribution).

I added bpm-platform.xml in META-INF directory with the following entries. but issue remains same. Still getting the same error. I am using camunda 7.9 version, Ojdbc6-
?xml version=“1.0” encoding=“UTF-8”?>
bpm-platform xmlns=“” xmlns:xsi=“
xsi:schemaLocation=" ">
Please Help. we are struck with this issue.

<process-engine name="default">
                 <property name="jdbcBatchProcessing">false</property>

Hi Ingo

I still get the same error after placing the bpm-platform. Xml under META-INF folder.

Please help.



Sent from Yahoo Mail on Android

Hi Ram,
Kindly paste the contents of your bpm-platform.xml and server.xml .

Sorry for the late. I am able to resolve this issue by setting the parameter using process api. Now I am not getting the error. Thank you so much for offering the help.

We are facing the same issue …
Oracle version - PL/SQL Release - Production
Using camunda-bpm-spring-boot-starter-webapp-ee
Spring-Boot: (v2.1.1.RELEASE)
Camunda BPM: (v7.10.0-ee)
Camunda BPM Spring Boot Starter: (v3.2.0)

Where do we need to add this property
name=“jdbcBatchProcessing” as false property ??
From the above posts, it seems processes.xml under META-INF is not the correct place ?

Exact trace log

ENGINE-08043 Exception while performing ‘Deployment of Process Application TestCamundaspringbootSeedApplication’ => 'Deployment of process archive ‘application-process-list’: ENGINE-03005 Execution of ‘UPDATE PropertyEntity[next.dbid]’ failed. Entity was updated by another transaction concurrently