Issue with Ubuntu installation (Camunda OSCE v. 7.16.0)

Good time for everyone!

I have an issue with Camunda (OSCE v. 7.16.0) installation on Xubuntu.

There is no error message at the installation process (not sure). But when I try to run:


it gives me result 404:

Whitelabel Error Page

This application has no explicit mapping for /error, so you are seeing this as a fallback.
Fri Dec 03 22:36:11 UTC 2021
There was an unexpected error (type=Not Found, status=404).

The same result for different ways of installation:

  1. ZIP bundle downloaded, JDK installed, and started. Have tried different versions JDK (Oracle 14; 17; Open JDK 11) and Xubuntu (18.04 LTS, 20.04 LTS, 21.10).
  2. Docker installation.

Though I can access Camunda through the URL:


It seems that there is something wrong with /camunda-welcome/index.html service, or it is no longer valid URL and the instructions on the Download page are terribly misleading.

With best regards,
Dmitry Kapinos

I setup the new system on XUbuntu, i could see the page.

JDK: OpenJDK 15.0.2
OSCE- V16.

Hi @dkapinos

Some distributions don’t yet have the camunda-welcomeapp.
Try accessing localhost:8080/camunda that should work for any disto.

Try to run Camunda BPM as non-root user.

If you run it as root user, i could reproduce the error what you mentioned in the post.

1 Like

Hello, cpbpm, Niall!

Yep, that is what I want.
But none of this doesn’t work for me.

Xubuntu 21.10, Oracle JDK 14.0.2

I’ve repeated installation process:

  1. Standalone installation from ZIP.
  2. Installation as Docker container (wich has OpenJDK 11.0.9 bundled).

The same results for both variants.

Here is video log of the process:

Am I doing something wrong?

Xubuntu 21.10, Open JDK 16.0.1

If I try Open JDK 16, it gives me Server Error. See:

Though documentation says:

Please make sure that you have the Java Runtime Environment 8+ installed.

If the latest version of Camunda works only with some special versions of Java on Linux (15.0.2, etc.), it probably should be explicitly mentioned in the installation instructions at the Download page, I think.

Niall, such short URL doesn’t work either (see the video above).

With best regards,
Dmitry Kapinos

I never started standalone Camunda as root. If I start it as root, the app crushes.

With best regards,
Dmitry Kapinos

Camunda document already states minimum JDK version. You may be missed to notice it.

What is the memory allocated to xubuntu system?

1 Like

Thanks, Chander, I’ve completely missed it from Download page. The colored line was kind of blind spot for me. It’s weird…

Though I intentionally searched for the information and found the next info in the official documentation:

= any version of Java above 8 is fine.

= any version of Java from 8 to 15 is fine.

I’ve also asked Camunda docker image which version it uses:


It uses 11th, and the same issue also present here. Can you check it to be sure?

4 Gb.
But I think that JDK version is a mine culprit.

And I wonder:

  1. How many those issue posts on the forum stem from the source (wrong choice of Java version)?
  2. Why such simple thing as a static html page (Welcome screen) should be so sensitive to Java version?