Java - Cannot login to http://localhost:8080/login with demo/demo

I followed the steps from this tutorial and created my first Java Project with Camunda but when I tried to login to Camunda in browser it says that I entered “Bad credentials”. Also, the page does not look like the welcome page of Camunda. It redirects me to the URL from the title.
I selected H2, in memory, Java version 11 (although I have version 17 on my PC).

Could you please advice what could be the reason? Should I install Java 11? Springboot should be installed?
Thank you!

Hi, Diana!

There is definitely a problem with Java v. 17. See:

Try Java v. 15 instead. Or try to rum Camunda through Docker image.

With best regards,
Dmitry Kapinos

1 Like

Hi Dmitry,
Thank you for your message. I tried with Java 11 and Java 15 but didn’t work. I searched on the forum and found out that the issue appeared because I checked the Security module on the website. I downloaded the project without Security and rerun the Java project.
It is working now! :slight_smile:


Thanks for posting the solution to your problem @DianaArti and also thanks for the great suggestion @dkapinos - i was thinking the same thing