JBoss Docker image error

Hi everyone!
First post around here and I got to say I’m not quite sure if this is the right place for my question.
If it’s not, please tell me where should I go.

Before I start, I also gotta say I’m pretty new to BPM/JavaEE/Camunda.
I’ve been poking around with Camunda and BPM for the last 3 weeks and everything was good until I decided to include Databases.
I’ve been able to create a process (a different one from the tutorials and that address the needs of the problem I’m trying to solve), configure some access from groups and users and simple stuff.

Then I’ve moved to the Java EE 6 tutorial and decided to do that with PostgreSQL database.
I tried the docker image Tomcat-7.4.0 with Postgres and that ran smoothly, it created the tables and every process was running ok, saving in the db with no errors.

Then I downloaded the docker image of Camunda-JBoss-7.4.0.
I ran with these comands: docker run -d --name postgresql -p 5432:5432 -e POSTGRES_USER=camunda -e POSTGRES_PASSWORD=camunda -e POSTGRES_DB=process-engine postgres:latest and docker run -d --name camunda -p 8080:8080 --link postgresql:db -e DB_DRIVER=org.postgresql.Driver -e DB_URL=jdbc:postgresql://db:5432/process-engine -e DB_USERNAME=camunda -e DB_PASSWORD=camunda camunda/camunda-bpm-platform:jboss-7.4.0

In the container log, I got this error:

H2 driver already defined in /camunda/standalone/configuration/standalone.xml
Adding MySQL driver to /camunda/standalone/configuration/standalone.xml
Adding PostgreSQL driver to /camunda/standalone/configuration/standalone.xml
Configuring database
  JBoss Bootstrap Environment
  JBOSS_HOME: /camunda
  JAVA: java
  JAVA_OPTS: -Djboss.bind.address= -Djboss.bind.address.management= -server -XX:+UseCompressedOops -Xms512m -Xmx768m -XX:MaxPermSize=384m -Djava.net.preferIPv4Stack=true -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true
03:37:30,801 INFO  [org.jboss.modules] (main) JBoss Modules version 1.2.0.CR1
03:37:31,032 INFO  [org.jboss.msc] (main) JBoss MSC version 1.0.4.GA
03:37:31,154 INFO  [org.jboss.as] (MSC service thread 1-2) JBAS015899: JBoss AS 7.2.0.Final "Janus" starting

03:37:33,381 INFO  [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) JBAS015003: Found camunda-welcome.war in deployment directory. To trigger deployment create a file called camunda-welcome.war.dodeploy
03:37:33,814 INFO  [org.jboss.as.server] (Controller Boot Thread) JBAS015888: Creating http management service using socket-binding (management-http)
03:37:33,819 INFO  [org.xnio] (MSC service thread 1-2) XNIO Version 3.0.7.GA
03:37:33,843 INFO  [org.xnio.nio] (MSC service thread 1-2) XNIO NIO Implementation Version 3.0.7.GA
03:37:33,906 INFO  [org.jboss.remoting] (MSC service thread 1-2) JBoss Remoting version 3.2.14.GA
03:37:34,016 INFO  [org.jboss.as.clustering.infinispan] (ServerService Thread Pool -- 30) JBAS010280: Activating Infinispan subsystem.
03:37:34,107 INFO  [org.jboss.as.jsf] (ServerService Thread Pool -- 36) JBAS012605: Activated the following JSF Implementations: [main, 1.2]
03:37:34,109 INFO  [org.jboss.as.naming] (ServerService Thread Pool -- 38) JBAS011800: Activating Naming Subsystem
03:37:34,143 INFO  [org.jboss.as.security] (ServerService Thread Pool -- 43) JBAS013171: Activating Security Subsystem
03:37:34,145 INFO  [org.jboss.as.connector.logging] (MSC service thread 1-1) JBAS010408: Starting JCA Subsystem (JBoss IronJacamar 1.0.15.Final)
03:37:34,235 INFO  [org.jboss.as.webservices] (ServerService Thread Pool -- 47) JBAS015537: Activating WebServices Extension
03:37:34,338 INFO  [org.jboss.as.naming] (MSC service thread 1-2) JBAS011802: Starting Naming Service
03:37:34,418 INFO  [org.jboss.as.security] (MSC service thread 1-2) JBAS013170: Current PicketBox version=4.0.15.Final
03:37:34,922 INFO  [org.jboss.as.mail.extension] (MSC service thread 1-1) JBAS015400: Bound mail session [java:jboss/mail/Default]
03:37:35,219 INFO  [org.jboss.ws.common.management] (MSC service thread 1-1) JBWS022052: Starting JBoss Web Services - Stack CXF Server 4.1.3.Final
03:37:35,329 INFO  [org.jboss.as.connector.subsystems.datasources] (ServerService Thread Pool -- 26) JBAS010403: Deploying JDBC-compliant driver class org.h2.Driver (version 1.3)
03:37:35,398 INFO  [org.apache.coyote.http11] (MSC service thread 1-2) JBWEB003001: Coyote HTTP/1.1 initializing on : http-/
03:37:35,467 INFO  [org.apache.coyote.http11] (MSC service thread 1-2) JBWEB003000: Coyote HTTP/1.1 starting on: http-/
03:37:35,489 INFO  [org.jboss.as.connector.subsystems.datasources] (ServerService Thread Pool -- 26) JBAS010404: Deploying non-JDBC-compliant driver class com.mysql.jdbc.Driver (version 5.1)
03:37:35,523 INFO  [org.jboss.as.connector.subsystems.datasources] (ServerService Thread Pool -- 26) JBAS010404: Deploying non-JDBC-compliant driver class org.postgresql.Driver (version 9.3)
03:37:36,325 INFO  [org.jboss.as.server.deployment.scanner] (MSC service thread 1-1) JBAS015012: Started FileSystemDeploymentService for directory /camunda/standalone/deployments
03:37:36,378 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015876: Starting deployment of "camunda-engine-rest-7.4.0.war" (runtime-name: "camunda-engine-rest-7.4.0.war")
03:37:36,383 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015876: Starting deployment of "camunda-webapp-jboss-7.4.0.war" (runtime-name: "camunda-webapp-jboss-7.4.0.war")
03:37:36,384 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015876: Starting deployment of "camunda-h2-webapp-7.4.0.war" (runtime-name: "camunda-h2-webapp-7.4.0.war")
03:37:36,384 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015876: Starting deployment of "camunda-welcome.war" (runtime-name: "camunda-welcome.war")
03:37:36,385 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015876: Starting deployment of "camunda-example-invoice-7.4.0.war" (runtime-name: "camunda-example-invoice-7.4.0.war")
03:37:38,616 INFO  [org.jboss.as.remoting] (MSC service thread 1-2) JBAS017100: Listening on
03:37:38,763 INFO  [org.camunda.bpm.container.impl.jboss.deployment.processor.ProcessApplicationProcessor] (MSC service thread 1-2) Detected user-provided @ProcessApplication component with name 'org.camunda.bpm.example.invoice.InvoiceProcessApplication'.
03:37:38,769 INFO  [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-1) JBAS010400: Bound data source [java:jboss/datasources/ExampleDS]
03:37:38,776 INFO  [org.jboss.as.remoting] (MSC service thread 1-1) JBAS017100: Listening on
03:37:39,923 INFO  [org.jboss.web] (ServerService Thread Pool -- 52) JBAS018210: Register web context: /camunda-welcome
03:37:40,031 INFO  [org.jboss.web] (ServerService Thread Pool -- 51) JBAS018210: Register web context: /h2
03:37:40,098 INFO  [org.jboss.web] (ServerService Thread Pool -- 53) JBAS018210: Register web context: /engine-rest
03:37:40,149 INFO  [org.jboss.web] (ServerService Thread Pool -- 57) JBAS018210: Register web context: /camunda-invoice
03:37:40,151 INFO  [org.jboss.web] (ServerService Thread Pool -- 56) JBAS018210: Register web context: /camunda
03:37:40,177 INFO  [org.camunda.bpm.application] (ServerService Thread Pool -- 57) ENGINE-07015 Detected @ProcessApplication class 'org.camunda.bpm.example.invoice.InvoiceProcessApplication'
03:37:41,592 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "camunda-example-invoice-7.4.0.war" (runtime-name : "camunda-example-invoice-7.4.0.war")
03:37:41,594 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "camunda-welcome.war" (runtime-name : "camunda-welcome.war")
03:37:41,595 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "camunda-h2-webapp-7.4.0.war" (runtime-name : "camunda-h2-webapp-7.4.0.war")
03:37:41,595 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "camunda-webapp-jboss-7.4.0.war" (runtime-name : "camunda-webapp-jboss-7.4.0.war")
03:37:41,596 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "camunda-engine-rest-7.4.0.war" (runtime-name : "camunda-engine-rest-7.4.0.war")
03:37:41,597 INFO  [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report
JBAS014775:    New missing/unsatisfied dependencies:
      service jboss.jdbc-driver.org_postgresql_Driver (missing) dependents: [service jboss.driver-demander.java:jboss/datasources/ProcessEngine, service jboss.data-source.java:jboss/datasources/ProcessEngine] 
03:37:41,618 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015961: Http management interface listening on
03:37:41,618 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015951: Admin console listening on
03:37:41,619 ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: JBoss AS 7.2.0.Final "Janus" started (with errors) in 11315ms - Started 359 of 435 services (6 services failed or missing dependencies, 68 services are passive or on-demand)

And when I try to access it gives this error:

So, I really don’t know what it’s happening. I’ve tried to google for the error, but all I get are no related problems (or at least it looks like it for me).

Appreciate any help!
And thanks!


the driver name for jboss/wildfly containers is postgresql. See README:

DB_DRIVER the database driver class name (Note: use for jboss and wildfly only the database identifier h2, mysql or postgresql)

As this is a common problem I created an issue to adjust the driver names to match the tomcat ones. Thanks for reporting the issue.



Thank you very much!

And I’m really sorry for this! I should’ve pay more attention to the documentation.
It was really in front of me the whole time!

Thank you!