Keycloak redirection url for camunda identity

Hello ,

I deployed a new instance of camunda 8 on a linux server using the following docker compose file :
[camunda-8-process-solution-template/docker-compose.yaml at main · camunda-community-hub/camunda-8-process-solution-template · GitHub]

I changed the identity issuer url for optimize , tasklist and operate (replaced localhost with the name of my server ) and the authentication worked as expected (user redirected to keycloak authentication page)
As for identity , I can’t find in the docs the variable that changes the issuer url , whenever I try to access the identity index page I’m redirected to the following link :
http://localhost:18080/auth/realms/camunda-platform/protocol/openid-connect/auth?client_id=camunda-identity&redirect_uri=

is there anyway to replace the localhost by the name of my server ??

Thanks

same problem here.
In addition to this, optimize’s redirect url was also registered using ‘localhost’ in keyclock client registration page. It worked after change the redirect url to right hostname. But I cannot find ‘localhost’ for identity.

1 Like

I guess I found. after line120, there might be another environment variable named ‘IDENTITY_AUTH_PROVIDER_ISSUER_URL’ should be specified. the value might be http://hostname:18080/auth/realms/camunda-platform

Hey you both @msjo66 and @mazenoddo

I think you have to set the following env var IDENTITY_AUTH_PROVIDER_ISSUER_URL

You can take a look at how it is done in the helm charts camunda-platform-helm/charts/camunda-platform/charts/identity/templates/deployment.yaml at main · camunda/camunda-platform-helm · GitHub

Greets
Chris

Ah I was too slow you already found it :slight_smile: :+1: