Making wildfly available on EC2

I’m messing about with EC2 on Amazon web services on the free tier.

I’ve taken the full camunda 7.6.0 wildfly dstro and unpacked it onto a RHEL instance on EC2.

What do i have to do to configure the server to make it available from a normal browser accessing the EC2 public IP address?

I thought that it would just be a case of modifying the JBOSS.BIND.ADDRESS but this doesn’t seem to work, what else should I be looking at?


Might be a little out of date - but there is a blog post you might find handy in answering some of your questions:

1 Like

Hi @theHornet,

it should work out of the box in general, I think you should only make sure that port 8080 or whatever port you are binding to is forwarded properly in AWS console and access it using AWS domain name, the long one.


1 Like

Hi @theHornet
also take a look into your standalone.xml within /server/wildfly-10.1.0.Final/standalone/configuration

The interfaces need to be configured correctly so it can be accessed from the outside.
Should look similar to:

         <interface name="management">
             <inet-address value=""/>
         <interface name="public">
1 Like

To my believing eyes, that looks awesome!

I’ll have a look when I get home tonight, what looks too easy is deploying a docker image of camunda. But hey-ho, I only know 2 things: 1) I don’t know anything about dockers and 2) never look a gift horse in the mouth.


Did a sed command to replace every instance of with my IP address, it started with a load of warnings. I’ll look at Niall’s blog and see how I get on.

This is what I was thinking was the issue and I didn’t know whether there was an out of the box approach in Camunda or (more probably) something in the AWS forums/docs about setting up another server and making it available through a browser (like setting up a LAMP architecture).

I’ll try Niall’s approach and report back.



If you already have an AWS instance deployed with camunda on it you’ll just need to set up a security group that lets you access it. I’d give that a go first - it’s pretty easy.

1 Like

Hi @theHornet
replacing every with your public IP address is not a good idea as the management interface should be accessed by only.
Did you try to specify only the public interface?