Message start event is not triggered

Hi All,

I am trying to follow the example of starting a process from another process. I created 2 simple processes (attached the bpmn files) and trying to trigger the message_start_event process from instantiating_process process using the Java code as shown below.

I am able to deploy the .war file on the server but when I trigger the first process (instantiating_process), the start even in the 2nd process doesn’t get triggered. Please advise.

Java Code :

public class InstantiateProcessByMessageDelegate implements JavaDelegate {

Logger LOGGER = LoggerFactory.getLogger(InstantiateProcessByMessageDelegate.class);

public void execute(DelegateExecution execution) {
RuntimeService runtimeService = execution.getProcessEngineServices().getRuntimeService();
//System.out.println(“Starting Process”);“Starting Process”);

instantiating_process.bpmn (3.0 KB)
message_start_event.bpmn (2.7 KB)

Hello @harish2610 ,

I’ve tried out your example. I believe everything works fine, but you just cannot notice the Startable process being started, as the task Wait in Message Process is no-op task. Engine does not do anything as the aforementioned task is neither service task (no Java logic) nor User task (wait state).

Engine just goes trough, instance ends immediately and you just do not notice anything. Try to make it User task and verify it again.


1 Like

Thanks @AdamLiberadzki It’s rookie mistake but this is my first process in camunda so glad it worked finally. Thanks for looking into it.