Missing engine-rest package on Camunda Standalone Webapp


I have downloaded Camunda Standalone Webapp war file (for Tomcat7) for my existing projects which is using Tomcat7.

After I read this https://blog.camunda.org/post/2015/08/start-and-complete-process-with-rest-api/ , I realise I am missing engine-rest package.

My questions :- Is there a engine-rest package for me to download? Instead of download the full camunda-tomcat package?

Thanks in advance,

1 Like

same here, I found the engine-rest package war and deployed but it doesn’t seem to be working. Is there any particular configuration needed?

Download > https://app.camunda.com/nexus/content/groups/public/org/camunda/bpm/camunda-engine-rest/

I’m curious about this too. I downloaded the standalone webapplication (camunda-webapp-tomcat-standalone-7.9.0.war) and deployed it to our pre-existing tomcat 8.0.2 server.

I’m wondering what is the rest URL for this standalone webapplication version of camunda? I’m getting 404s for the documented url of /engine-rest/engine/default.

After looking at the standalone war’s web.xml I tried hitting the /api/engine/default url but that doesn’t seem to get me much. I receive some json NotFoundExceptions returned with a message that a “resource could not be found for relative /default/task” at that url.

I also installed the engine-rest package war that sgru and rodneivete mentioned but I’m not sure how to configure it to connect to the embedded engine in the standalone war.

Hi Ben,

Which documentation are you referring to?

Best regards,

Hi @Yana,

I was looking at the documentation here:

The default process engine is available out of the box by accessing /engine-rest/engine/default/{rest-methods} or simply /engine-rest/{rest-methods}.

I was able to receive some simple json back when I performed a HTTP GET to
/api/engine/engine. The response to that GET contained the word “default” to indicate the name of the process engine. Should I be doing something different to access REST in the standalone war WAR distribution?

Thank you.

Hi Ben,

Basically rest usage described in the mentioned docs is only for share engine and doesn’t work for standalone webapplication.
In case of standalone web app you can try to use the camunda webapps rest api, so try to access:

Hope this helps.

Best regards,

Hi, thx that help. Can you tell me what the right url is to deploy a bpmn from the modeler to the standalone web app?

Have you tried camunda/api/engine/engine/default/deployment/create?


I get a response code 401

Hi Marcin,

I checked with my colleagues.
Unfortunately the deploy button from the Modeler cannot be configured with the webapps rest api.
Because you will need to configure a session and this is not possible.
The deployment from the Modeler can be setup only with Rest API without authentication.

Best regards,

So is it possible to install the Rest-Api beside the Standalone Web App ?

It is possible, however it won’t work with the engine inside of standalone web app, you need to setup share engine.

Ok thx, i think i can continue my work. Last Question : Do you see advantages to use the standalone process engine?

Hi Marcin,

Standalone web application is an option to use Camunda as embedded process engine.
You might be interested at this post.

Best regards,

Hi @Cheong_wai_kit

I am also try to use camunda standalone war but I dont know how to add my process (with servic task)inside this war can you suggest me.

Hi All,

How to pass the source in the deployment rest API of Camunda. I was following Reference.

But my API response is comping but the source is coming null.
Please find below attached for the request and response.



Thanks & Regards,

Hi Vinit,

The source is null as you did specify in the request body via deployment-source, have a look at https://docs.camunda.org/manual/7.8/reference/rest/deployment/post-deployment/#request-body

Just keep in mind that this question seems to be not so relevant to the original post, maybe a new post will be better in this case in the future.