Modeler Self Managed - Cannot conenect to Zeebe cluster

Hello,

I am in the process of installing a self-managed version of Camunda 8 on our server for smaller purposes. I have managed the installation so far through the documentation, blog posts and research and all instances are running smoothly on my Kubernetes + Docker instance. However, I now have the problem that I cannot deploy my models to Zeebe with the desktop modeler. I always get the error “Cannot connect to Zeebe cluster”.

I have already created and integrated SSL certificates. The pages of Tasklist, Optimize, Identity, Operate, etc. are working fine. Only Zeebe cannot be accessed. Does anyone have a solution?

I could not execute the last step from the Camunda Part 2 blog because I always get an error:

zbctl status --certPath zeebe.HOSTNAME.cer --address “zeebe.HOSTNAME:443”
Error: rpc error: code = Unavailable desc = connection error: desc = “transport: Error while dialing: dial tcp: lookup zeebe.HOSTNAME on XXX.XXX.XXX.XXX:XX: no such host”

Could this be the reason? If so, how can I solve the problem? I’m at the end of my tether.

Thanks in advance.
Best regards

kind.config:

kind: Cluster
apiVersion: kind.x-k8s.io/v1alpha4
nodes:
  - role: control-plane
    kubeadmConfigPatches:
      - |
        kind: InitConfiguration
        nodeRegistration:
          kubeletExtraArgs:
            node-labels: "ingress-ready=true"
    extraPortMappings:
      - containerPort: 80
        hostPort: 80
      - containerPort: 443
        hostPort: 443
      - containerPort: 26500
        hostPort: 26500
      - containerPort: 18080
        hostPort: 18080
global:
  ingress:
    enabled: true
    className: nginx
    host: "HOSTNAME"
    annotations:
      ingress.kubernetes.io/rewrite-target:
      nginx.ingress.kubernetes.io/ssl-redirect: "true"
    tls:
      enabled: true
      secretName: "tls-secret"
  identity:
    auth:
      enabled: true
      publicIssuerUrl: "https://HOSTNAME/auth/realms/camunda-platform"
      operate:
        redirectUrl: "https://HOSTNAME/operate"
      tasklist:
        redirectUrl: "https://HOSTNAME/tasklist"
      optimize:
        redirectUrl: "https://HOSTNAME/optimize"

identity:
  enabled: true
  contextPath: "/identity"
  fullURL: "https://HOSTNAME/identity"
  firstUser:
    enabled: true
    username: "admin"
    password: "..."
    email: "..."
    firstName: "..."
    lastName: "..."
        
identityKeycloak:
  enabled: true
  auth:
    adminUser: admin

operate:
  enabled: true
  contextPath: "/operate"

optimize:
  enabled: true
  contextPath: "/optimize"

tasklist:
  enabled: true
  contextPath: "/tasklist"

zeebe:
  enabled: true
  clusterSize: 1
  partitionCount: 1
  replicationFactor: 1
  pvcSize: 10Gi
  resources: {}
  initResources: {}

zeebeGateway:
  replicas: 1
  contextPath: "/zeebe"
  ingress:
    grpc:
      enabled: true
      className: nginx
      host: "zeebe.HOSTNAME"
      tls:
        enabled: true
        secretName: "tls-secret-zeebe"

connectors:
  enabled: false
  inbound:
    mode: disabled

elasticsearch:
  resources: {}
  initResources: {}
  replicas: 1
  minimumMasterNodes: 1
  master:
    replicas: 1
  # Allow no backup for single node setups
  clusterHealthCheckParams: "wait_for_status=yellow&timeout=1s"

  # Request smaller persistent volumes.
  volumeClaimTemplate:
    accessModes: [ "ReadWriteOnce" ]
    storageClassName: "standard"
    resources:
      requests:
        storage: 15Gi

Hey,

did you find a solution for this? I am getting the same error for zeebe (while tasklist and the other components are accessible).

Best regards

Are you able to deploy from the web modeler? If not, give a try with web modeler and see if that works.

The config should be something like below:

Client ID and secret will be of Zeebe that you can find in Identity. oAuthURL will be auth token URI and not the one publicIssuerUrl.

Please share the screeshot or more details if the above doesn’t work for you.

Hi,

@maiksfd unfortunately not yet. I haven’t received a call back from support either, even though I reported my problem.

@Arjun1007 As I don’t use the Enterprise Edition, I don’t know whether you can use the Web Modeler. I have tried the desktop version and the connection shouldn’t be any different in that respect, should it?

Best regards

Hey,

i found out that inside my cluster environment i am able to execute the zbctl status command (for zeebe.camunda.local:443) successfully. But outside in Windows (i am running the cluster inside WSL2 Ubuntu locally) it did not work. I am pretty sure you will experience the same if you try to execute the zbctl command directly on your server.
I don’t know why you can access the other components from outside and not the zeebe-gateway…

As my goal is to create a REST-API that uses a gRPC-Client to communicate with zeebe i will now just implement an API inside my cluster environment so i don’t have to try to connect to zeebe from outside (windows). I will use the Desktop Modeler to create BPMN-Files and my API to deploy them.

I don’t know your use case but maybe you can follow a similar approach.

Oh and btw i found out that in Camunda 8.6 they will expand the REST-API for zeebe so maybe you don’t even need the whole gRPC thing anymore in the near future.

Best regards