Multi-Diagram plugin

Good morning everyone! :grin:

Using the latest camunda-modeler-plugin-helpers package version, we had the opportunity to integrate multi-diagram on our own plugin without any outer implementation, as described on my previous topic.
I am glad to present our new multi-diagram plugin! Check it out and tell me if you like it!

Or…Just download the zip file and extract it to your plugin directory :grin:



This is really cool stuff :clap:

Mind you sharing your plugin on our GitHub collection?

1 Like

Sure! :slight_smile:

Awesome plugin! My only suggestion would be to not make switching diagrams a command since it doesn’t actually change anything except for the view. For the same reason changing tabs in the Camunda Modeler is not a command.


Great job, congratulations!

When unzipping the folder in version 4.2 of Modeler you are getting the following error message:

[diagram_1.bpmn] Cannot read property ‘getFormsTab’ of undefined
at GeneratedFormPreviewPluginProvider.getTabs (webpack:///client/GeneratedFormPreviewPluginProvider.js:22:0)
at GeneratedFormPreviewPluginProvider.CallActivityExt.propertiesProvider.getTabs (webpack:///client/properties-provider/CallActivityExt.js:71:0)
at getTabs (webpack:///node_modules/bpmn-js-properties-panel/lib/PropertiesPanel.js:446:41)
at file:///D:/Camunda/Modeler%204.2/resources/app.asar/public/5.5.js:1:97811
at file:///D:/Camunda/Modeler%204.2/resources/app.asar/public/2.2.js:1:45005
at listener (webpack:///node_modules/diagram-js/lib/core/EventBus.js:365:33)
at _invokeListener (webpack:///node_modules/diagram-js/lib/core/EventBus.js:350:23)
at _invokeListeners (webpack:///node_modules/diagram-js/lib/core/EventBus.js:311:23)
at fire (webpack:///node_modules/diagram-js/lib/core/Canvas.js:477:13)
at setRootElement (webpack:///node_modules/bpmn-js/lib/import/BpmnImporter.js:112:17)
at add (webpack:///node_modules/bpmn-js/lib/import/Importer.js:53:24)
at file:///D:/Camunda/Modeler%204.2/resources/app.asar/public/5.5.js:1:29935
at rootElement (webpack:///node_modules/bpmn-js/lib/import/BpmnTreeWalker.js:215:24)
at file:///D:/Camunda/Modeler%204.2/resources/app.asar/public/5.5.js:1:356935
at file:///D:/Camunda/Modeler%204.2/resources/app.asar/public/5.5.js:1:356958
at new Promise ()
at F (webpack:///node_modules/bpmn-js/lib/import/Importer.js:72:9)
at file:///D:/Camunda/Modeler%204.2/resources/app.asar/public/5.5.js:1:362018
at new Promise ()
at A. (webpack:///node_modules/bpmn-js/lib/BaseViewer.js:286:9)
at apply (webpack:///node_modules/bpmn-js/lib/util/CompatibilityUtil.js:50:17)
at file:///D:/Camunda/Modeler%204.2/resources/app.asar/public/5.5.js:1:361502
at new Promise ()
at A. (webpack:///node_modules/bpmn-js/lib/BaseViewer.js:228:9)
at apply (webpack:///node_modules/bpmn-js/lib/util/CompatibilityUtil.js:50:17)
at file:///D:/Camunda/Modeler%204.2/resources/app.asar/public/5.5.js:1:360771 [ error ]
This error may be the result of a plug-in compatibility issue. [ info ]
Disable plug-ins (restarts the app) [ info ]
[diagram_1.bpmn] Cannot read property ‘id’ of undefined
at file:///D:/Camunda/Modeler%204.2/resources/plugins/camunda-modeler-plugin-multidiagram/client/client.js:514:93
at file:///D:/Camunda/Modeler%204.2/resources/plugins/camunda-modeler-plugin-multidiagram/client/client.js:28190:9
at forEach (webpack:///node_modules/min-dash/dist/index.esm.js:145:0)
at find (webpack:///node_modules/min-dash/dist/index.esm.js:77:0)
at DiagramUtil…/client/bpmn-js-extension/multi-diagram/utils/DiagramUtil.js.DiagramUtil.currentDiagram (webpack:///client/bpmn-js-extension/multi-diagram/utils/DiagramUtil.js:23:0)
at file:///D:/Camunda/Modeler%204.2/resources/plugins/camunda-modeler-plugin-multidiagram/client/client.js:993:38
at file:///D:/Camunda/Modeler%204.2/resources/app.asar/public/2.2.js:1:45005
at listener (webpack:///node_modules/diagram-js/lib/core/EventBus.js:365:33)
at _invokeListener (webpack:///node_modules/diagram-js/lib/core/EventBus.js:350:23)
at _invokeListeners (webpack:///node_modules/diagram-js/lib/core/EventBus.js:311:23)
at fire (webpack:///node_modules/bpmn-js/lib/BaseViewer.js:662:30)
at file:///D:/Camunda/Modeler%204.2/resources/app.asar/public/5.5.js:1:360981 [ error ]
This error may be the result of a plug-in compatibility issue. [ info ]
Disable plug-ins (restarts the app) [ info ]

Hi @Antonio_Junior! :slight_smile:

I wrote you a PM. Please let me know!

Hello, the plugins I’m using are:

  • bpmn-js-token-simulation-plugin-master;
  • camunda-modeler-plugin-usertask-generatedform-preview


@daimadoshi85 I always wanted to build this plugin and you just did it. Awesome!

1 Like

Updated the project as suggested by @philippfromme and fixed a bug occurred on switching file tabs. Thank you very much for your help and enthusiasm!

1 Like

Hello @daimadoshi85,

Your multi-diagram plugin is exactly what I am searching to create my models in Camunda. But, as a beginner user I cant’t undestrand what happens after extract the plugin in my plugin directory. I have always an error message Sans titre .

Do I have to do something after doing this extraction?

Thank you for your attention.

Hello @joao ,
no, you don’t. What version of Camunda Modeler do you have installed?

I am using

1 Like

Ok. I’ll try to update mine asap (I use 4.5.0) and see what happens.

1 Like

OK, Thank you so much!

Unfortunately I’ve installed 4.5 version and I have the same message error.

Solved. For anyone who encountered the same issue, please make sure to copy the plugin folder to camunda-modeler/resources/plugins folder.

I am still facing the same issue multi-diagram model plug-in error. Modeler version 4.12.0.
I have dropped it inside camunda-modeler/resources/plugins folder. Please help

Hello @Subha1208
Can you show me the multidiagram folder hierarchy in resources/plugin please? Did you use the release zip or directly the cloned repository?

@daimadoshi85 Thank you for making a cool plug-in :slight_smile:

I’m a newbie, and I’m using the desktop modeller.

I’ve installed the plug-in, and I’m also able to create a sub-diagram, but it looks like, it’s not working with the Camunda platform 8.1, and I can’t even select some of the properties, which I can see in your demo.

In your demo, I can see that you’ve created the example on the 7.17 platform. I’ve tried this as well, and I’m able to link diagrams, but when I click on the “+”-icon, nothing happens, and when I upload the BPMN file to the cloud console, I’m getting an error. Do you have a version of the plug-in, which is compatible with the 8.1 platform?

Best regards,

Hello @Gunnar.H !
I sincerely never tried the plugin on Camunda platform, and unfortunately I am not on the project anymore. My last work was to make the plugin compatible with Camunda Modeler 5.x and (should) be compatible also with Camunda Platform, as a plugin, but that doesn’t mean it could work on execution.
I am sorry, I probably can’t help you. Try anyway to make an issue on the github project.
All the best,

1 Like