Not able to set up the camunda platform

I am trying to setup camunda platform for the first time for my application. But i am getting exception and its not displaying the default index.jsp even.

Hi @Monika
What exactly steps have you executed to run Camunda? What exception do you see?

I followed this document, installed camunda and started the server and tried to access the url in browser
but i am getting exception there

Moreover i could not deploy a new diagram because it says no rest api is configured.
I am not sure if some default configuration is there or need to do it from scratch.

“I followed this document,” - what document do you mean? I do not see any links in your reply.

Do you see any errors during the application startup in the terminal?

No errors during startup in the terminal, exception is thrown while trying to access the url

What operating system do you use?

Windows 10

Give it a try with the following link http://localhost:8080/camunda/app/welcome/default/

Hi @Niall
I can reproduce the described behavior locally. It looks like either problem or outdated documentation but http://localhost:8080/camunda-welcome/index.html link does not work. You might want to take a look at it.

1 Like

I am attaching the server error logs and browser screenshot, Its still not working

camundaBPMErrorLogs.txt (40.6 KB)

What version of Java is in use?

Do you see the same error when you try to log into the application? Have you tried to log in?

java 16 is in use and i dont have login credentials so didnt try to login.

  1. According to the official docs Camunda 7.16 supports Java up to version 15 - Supported Environments |
    You need to downgrade Java to version 15 and give it another try.

  2. The default credentials for admin access to the web apps are: Username: demo, Password: demo.

1 Like