Npm install camunda-external-task-client-js

Hello Community,

I have seen some posts regarding this problem.
I am using Visual Studio Code. NodeJS has been installed correctly.
I am following Niall’s tutorial (

When nmp install command is run against camunda-external-task-client-js it does nothing but throwing this error :

PS C:\Users\xxx> npm install camunda-external-task-client-js
npm ERR! request to failed, reason: unable to get local issuer certificate
npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\xxx\AppData\Local\npm-cache_logs\2021-12-17T13_47_58_447Z-debug.log

I have check this link node.js - Fixing npm path in Windows 8 and 10 - Stack Overflow, but it doesn’t fix the problem.

Does anybody may help me ?

Thanks a lot.


Hi Ben,

This thread on GitHub might help: Nodejs 4 introduces UNABLE_TO_GET_ISSUER_CERT_LOCALLY error for users behind company firewalls · Issue #3742 · nodejs/node · GitHub

Hello Tassilo,

Best wishes for 2022.
I have analysed what’s behind the link.
I fired command “npm config set registry”.
This gives no error nor messages.

Then I fired “npm install camunda-external-task-client-js”
It gave this:
npm ERR! code E403
npm ERR! 403 403 Forbidden - GET
npm ERR! 403 In most cases, you or one of your dependencies are requesting
npm ERR! 403 a package version that is forbidden by your security policy, or
npm ERR! 403 on a server you do not have access to.

If I try to access the link I do not have any problem: I do have access to it.
I assume, my local Camunda engine is not allowed to access it.
Is this correct ?
If so how to fix this ?

URL http is used instead of https. May this be related to my issue ?

Update 2:
npm install anything (I mean “really” anything) gives same error.
Must be connected to NodeJs (my version is 16.13.1)

Update 3: error source found : no proxy settings set !
I launch this command npm config set proxy myproxy:xxxx – full url and port