Polling not happening in Node js when trying to set process variable for Camunda

I am trying to run Camunda process with Node js. I am trying to set process variable value through Node js. I have followed steps from Niall Deehan’s video. The issue is,when I execute node command, I get the message “subscribed to topic DecideOnExpansion(my topic name)” and nothing else. It doesn’t show polling happening. I retried to start a new instance but it still the same. Could anyone please help me?

Hi @Kritika_Srivastava
Can you show the code for the worker, the process that you’ve deployed and also the logs that are produced by the worker and i’ll try to help you out :slight_smile:

Hi Niall,
Thanks for the response!! Below is my worker with its logs:

Also below is my process :

Token is not moving further as Its not receiving the value of topic ‘DecideOnExpansion’ from node.js since polling is not happening as shown in your video Tutorial: How to Use Camunda Enterprise Edition in a Distributed System (Video 3) - YouTube

Kindly help me out. Also I could not see server folder in my Camunda location, could you please suggest what could be wrong as I am not able to run through Java as well.

Many Thanks,

It seems worker looks good. Subscription occurs.
There are 2 main problems with “no polling”.
First is check model and Topic name.
Second, check property of tomcat jobExecutorDeploymentAware and try to set it to “false” value.

This is really good advice - i’d say that it’s Maxim has probably found the most likely problem

Hi Niall,

Thanks for getting back. :slight_smile: I have stuck into new problem before I try the solution suggested. I had to change port in server file from 8080 to 9090. After that I am able to get welcome page but not able to deploy any process as its taking 8080 only by default. Below is the error I am getting :

I think I need to set it somewhere in any of configuration file, Please suggest.


It is editable field, and modeller pings socket for reply, just enter localhost:9090/engine-rest

1 Like

Hi MaximMonin,

Yes I had changed it to 9090 from 8080 but was appending ‘’ to end of url localhost:9090\engine-rest\rest , so that is why it was not working.

It worked when I removed ‘’. Thanks for the response. :slight_smile: