Prevent Incrementing Versions of Unchanged BPMN Models in Spring Boot with Camunda Engine

Hello, I’m currently working with a Spring Boot application integrated with the Camunda BPM engine (version 7.19.0). I noticed that my application does not include the @EnableProcessApplication annotation in the Application class. My goal is to deploy the application on a remote server without incrementing the versions of BPMN models unless they have been modified. Ideally, only the BPMN models that have changes should have their versions incremented upon deployment.

To achieve this, I attempted to use the property camunda.bpm.application.deploy-changed-only = true in my file, hoping it would instruct the Camunda engine to only deploy models that have undergone changes. However, it appears that Spring does not recognize this configuration property, and my objective is not met.

Has anyone faced a similar issue or can provide guidance on how to configure the deployment process to update only those BPMN models that have actually changed? Any insights or suggestions would be greatly appreciated.

Hi @pertsh.galstyan
Do you extend SpringBootProcessApplication class somewhere in your code?
If you do then even if you don’t use @EnableProcessApplication annotation in the code it might interrupt the work of camunda.bpm.application.deploy-changed-only = true.


Hi @Alex_Voloshyn , thank you for your response , no I am not extend SpringBootProcessApplication anywhere in my code

Could you create and share the simplest project to illustrate the problem? (and attach it here). This can simplify the investigation process.

Hello @Alex_Voloshyn, I’ve made a change to the parameter from camunda.bpm.application.deploy-changed-only = true to , and it’s now recognizing the parameter and functioning correctly. I discovered this solution in one of your replies on a similar topic, so I wanted to express my gratitude. Thank you!

@pertsh.galstyan Thanks a lot for the feedback :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.