Problem compiling maven project and downloading war from nexus

I have two issues kind of related:

  1. I’m new to camunda and have tried to compile in eclipse a camunda githup showcase example that I have dowloaded from github. When I try to compile the pom.xml with maven clean install , I have the following error message :


[ERROR] Failed to execute goal org.apache.maven.plugins .... Compilation failure
[ERROR] No compiler is provided in this environment. Perhaps you are running on a JRE rather than a JDK?


I have tried to apply the following solution but with no success:

  1. I have then decided to download directly the camunda showcase SNAPSHOT war file from nexus, but it seems that I can download because I’m not signed in and I do not find any sign up link

Thanks in advance for your help

After you choose to use the JDK in eclipse remove the JRE that you used before and it should work.

Hi Niall,

How to know the JRE I was using before and to remove it ?
My eclipse is installed on Centos 7 and I use it through a windows PC by ssh the Centos Box:



I have tried different things :

  1. Adding jdk path to eclipse.ini but not working after maven update project:




  1. Adding a new JDK in eclipse but not working after maven update project:


  • Locating Java > Installed JREs .
    * Afterwards, the screen will show the list of JREs.
    * Clicking on Add button, locate the new folder on your machine and select.
    * Removing the old JRE from the list.


So does someone knows how to get the snapshot war file from nexus ? because it looks like I have to sign in but I do not have the sign up option

Thank you!

Installing maven with yum command, and after maven build clean install in eclipse allowed to generate the war file.