Problem with camunda form

Hallo, i cant get a form for a user task to work:

CreateSurveyProcess.bpmn (3.0 KB)

ProvideSurveyDataForm.form (332 Bytes)

User task ‘ProvideSurveyData’ should have the form in cockpit.

the process is under


and the form under


I followed

I tried all variations of form key:

  • camunda-forms:deployment:ProvideSurveyDataForm.form
  • camunda-forms:deployment:forms/ProvideSurveyDataForm.form
  • camunda-forms:app:ProvideSurveyDataForm.form
  • camunda-forms:app:forms/ProvideSurveyDataForm.form

but i only get in cockpit:

Please help:)


I have a similar problem. I have also tried putting under static/forms which works for an embedded form I have.

What version of Camunda Platform and what Version of the Camunda Modeler are you using?
Also are you using spring boot?

For my it 7.16, modeler 4.11.1, and springboot.

Hi @Stefan_Schulz and @StuRyan56,

please have a look at this thread: Form Failure - No Camunda Form Definition was found - #10 by Ingo_Richtsmeier

Hope this helps, Ingo