Problem with forms in Java Spring Boot

I want to add a form to a human task in Java Spring Boot distro. According to this tutorial, I put my form inside resources/static/forms directory, and set the forms attributes of my human task as below:

(the form file name, and also its id are pin-code)
But, this doesn’t work. I had done this in another project and it had worked. I am confused what the problem is now.

In other distros (Camunda Run/TomCat), I did this simply by setting Camunda-Forms as Forms Type, and <my-form-name> as Form Ref. But this didn’t work in Java Spring Boot. I also tried to do this way:

But, this didn’t work either.
Could anyone possibly help me with this?

Thanks in advance

Hi @NSh,

when you want to reference forms from the spring-boot application, try camunda-forms:app:forms/pin-code.form as form-key. See User Task Forms | for further details.

The alternative is to reference the forms from the database using form-reference.

And to deploy them into the database you have to extend the deployment resources in the configuration.
Use either the .deployment-resource-pattern if you did not use a process application (Process Engine Configuration |

or configure with <property name="additionalResourceSuffixes">form</property> in processes.xml in case you use the annotation @EnableProcessApplication (Process Archive Configuration |

Hope this helps, Ingo

1 Like

Hi @Ingo_Richtsmeier,
Thanks a lot for your explanations.
I just found out what was the problem when using camunda-forms:/forms/pin-code.form as form key. I had added static.forms as a directory in resources directory. I removed it and added first static directory and then forms directory inside it. Now, it is working fine!