Problem with Tutorial - Simple Demo

The process could not be started. :
Cannot instantiate process definition SimpleDemo:1:b96c60fb-2e02-11e8-97e4-1a1525545d62: ENGINE-02033 Delegate Expression ‘com.camunda.demo.SimpleDemo.CheckWeatherDelegate’ did neither resolve to an implementation of ‘interface org.camunda.bpm.engine.impl.pvm.delegate.ActivityBehavior’ nor ‘interface org.camunda.bpm.engine.delegate.JavaDelegate’.

Any idease why I get this error?

Hi Gary,

Which tutorial do you follow?

Best regards,

I’m following the Learn Camunda with Niall first tutorial

I think you might need to change your service task implementation from delegate expression to java class

If this doesn’t work - then upload your model and i’ll take a look at it.

changed to a Java class and same error message

attached: my file

process.bpmn (6.23 KB)

Your check weather task has the file location of the java class but it needs the qualified name.
you’ve got :
but you need the qualified name, the same way you’ve done for the print complaint task

basically - you should not see slashes in the name.

1 Like

Eclipse generated the qualified name. I fixed the slashes - no go
also reverted back to a delegate expression and still no go
I appreciate your help…great service

as an aside - in another test project I’m getting cannot find form error
I’m sure paths are an issue here

I just want to make sure you’re getting the actual qualified name - can you take a look at this screen shot:

A common mistake is the click on the FILE not the CLASS object. If you did this it would explain how you managed to get the file path and not the class path

Yep-- did it that way.
Re-did it and now my deployed war is scambled. ie It is not
recognized as a process in Camunda.
I think I’m fighting tomcat problems. The war is in webapps and I deploy
it bit when I look at the process it displays as an ascii file and not
a graph.
I think I’m wasting your time as I am just a hobbyist. Maybe the
quickest way fro me to learn this is to see the Eclipse or Netbeans
project itself and try and get it wotking form there. As I mentioned
I’m having trouble with forms as well.

Thanks again for all your efforts



  1. reinstalled Camunda
  2. rebuild Maven archetypr for camunda
    3)fixed typ0 - weatherOk vd weather OK

works like a charm !