Problems with Camunda Cycle (Git <> Filesystem)

Hit there,

I’m trying to use Cycle to sync between Git and the local file system. I added the connectors and tried to create a roundtrip. The Git connector worked fine and I was able to access my repository and select the BPMN file. After that I was about to connect the local file system. But when I try to sync the files I receive an error:

Authorization credentials are correct as I tested them a couple of times. The crazy thing is that the file is still downloaded to my local system. So I basically could work with the files locally but I can’t sync them back to the Git repo as I still receive this error.

Does anyone have an idea what to do or what I am doing wrong? Will Cycle even developed on as the latest version is from december 2014?

Thank you!

Hi @marcel6t,

can you try to push using command line? Is that working?


Hello @aakhmerov,

I tried cloning the repo with TortoiseGit, which worked fine. I was able to pull and push, so there should not be a problem with the credentials… :frowning:

Hi @marcel6t,

is your tortoise git using https url or ssh connection?

Hello @aakhmerov,

I used HTTPS for my connection.

EDIT: I changed the connector to SSH and this worked! I still don’t know what the problem with HTTPS is, but SSH works.

So thanks to @aakhmerov… I haven’t even thought about using SSH before you asked… :smiley: