Run as Spring Boot App failed in eclipse

I am trying to create a spring boot camunda application. I am able to compile, but when i ran i am getting the class not found exception.

pom.xml (6.3 KB)

Caused by: class path resource [org/springframework/web/servlet/config/annotation/WebMvcConfigurerAdapter.class] cannot be opened because it does not exist
at ~[spring-core-4.3.11.RELEASE.jar:4.3.11.RELEASE]
at org.springframework.core.type.classreading.SimpleMetadataReader.( ~[spring-core-4.3.11.RELEASE.jar:4.3.11.RELEASE]
at org.springframework.core.type.classreading.SimpleMetadataReaderFactory.getMetadataReader( ~[spring-core-4.3.11.RELEASE.jar:4.3.11.RELEASE]
at org.springframework.boot.type.classreading.ConcurrentReferenceCachingMetadataReaderFactory.createMetadataReader( ~[spring-boot-1.5.7.RELEASE.jar:1.5.7.RELEASE]
at org.springframework.boot.type.classreading.ConcurrentReferenceCachingMetadataReaderFactory.getMetadataReader( ~[spring-boot-1.5.7.RELEASE.jar:1.5.7.RELEASE]
at org.springframework.core.type.classreading.SimpleMetadataReaderFactory.getMetadataReader( ~[spring-core-4.3.11.RELEASE.jar:4.3.11.RELEASE]
at org.springframework.context.annotation.ConfigurationClassParser.asSourceClass( ~[spring-context-4.3.11.RELEASE.jar:4.3.11.RELEASE]
at org.springframework.context.annotation.ConfigurationClassParser$SourceClass.getSuperClass( ~[spring-context-4.3.11.RELEASE.jar:4.3.11.RELEASE]
at org.springframework.context.annotation.ConfigurationClassParser.doProcessConfigurationClass( ~[spring-context-4.3.11.RELEASE.jar:4.3.11.RELEASE]
at org.springframework.context.annotation.ConfigurationClassParser.processConfigurationClass( ~[spring-context-4.3.11.RELEASE.jar:4.3.11.RELEASE]
at org.springframework.context.annotation.ConfigurationClassParser.processImports( ~[spring-context-4.3.11.RELEASE.jar:4.3.11.RELEASE]
… 15 common frames omitted

Do you build camunda-spring-boot from github sources or do you use a certain version dependency?

I configured eclipse with remote camunda catalog for downloading archetypes.

Please do let me know if you need more info.

I never worked with the archetypes, so I would if possible have to see the code (maybe you can provide a minimal failing example on github) or the exact version of starter, camunda, spring , archetype and java you are using to reproduce.

I sent you the screen shot of archetype of starter.

Windows 10 Pro 64 bit.
Eclipse Oxygen 64 Bit
Java 1.8.171 64 bit.

In your screenshot it looks like you are trying to use 7.8.2.
This would mean you are trying to use the enterprise version of camunda.
Have you configured your maven correctly so that it has access to the private repositories for the EE?

I am pulling it from nexus as i configured remote catalog in eclipse. I thought 7.8.2 was the latest version shown in archetype.

You are right, you were referring to the Archetype Version not Camunda BPM dependencies.

Have you changed anything in the pom.xml after creating the project using the maven archetype?
Is Eclipse showing any errors?
Can you verify that all dependencies have been downloaded successfully?

I am able to compile code sucessfully, there are no errors. build was successful. It downloaded all the dependencies from pom.xml, i did not make a change in pom.xml

Only problem is that when i run the application as Spring Boot application, it throws an error.