Serialization problem - Switch to XML

Hello, we do have a Problem. We made several developments and Deployments and everything worked well. We are using automatic serialization, what was normally JSON.
Suddenly the serialization switches from application/json to application/XML and we do get deserialization Errors if it is on XML.

Sometimes it is stable on JSON (and working) sometimes after deployments it switches to XML.
What we found is:

  • Configuration will be done in in Engine (no changes possible because we are using the official docker)

If you have any hint, what could it be, would be great. Thanks.

I assume you have some REST methods implemented in JAX-RS? Then a simple @Produces annotation should do the trick:

public Response getMeSomeCoffee()

Thanks for the idea. We are using for the implementation Play! 1.53 / This has only JSON implemented.
Out of any reason the Camunda is changing in SPIN to XML, even it is a JSON object.
We are having interfaces working only with JSON or only with XML. Very strange.

We will now try to change the model from Object to String.
But it is of course not the prefered solution.

Finally we found not a solution, but a Workaround.
All objects using REST and JSON are now declared as JSON. So the machine has no possibility to switch. The communication works now fine.

Hi @chjmichel,

how did you configure your SPIN plugin? Do you use

If yes, does the behaviour change if you configure camunda-spin-dataformat-json-jackson instead of -all?

Cheers, Ingo