Setting context path or Maven <warName> leads to ENGINE-08043 error

I’m using camunda in Eclipse IDE. In gernal the set up is fine and the engine is runnig but I dont’t want to have my app available under the artifact ID like / - I want to have it under /myapp/.

I configured maven build like this in pom.xml:


The build looks fine. But when I start the server it shows an:

SCHWERWIEGEND: Exception sending context initialized event to listener instance of class de.materna.dzf.rechenkern.RechenkernApplication
org.camunda.bpm.engine.ProcessEngineException: ENGINE-08043 Exception while performing 'Deployment of Process Application ...' => 'Start Process Application Service': Cannot register service org.camunda.bpm.platform.job-executor.process-application:type=... with MBeans Container, service with same name already registered.
	at org.camunda.bpm.container.impl.ContainerIntegrationLogger.exceptionWhilePerformingOperationStep(
	at org.camunda.bpm.container.impl.spi.DeploymentOperation.execute(
	at org.camunda.bpm.container.impl.jmx.MBeanServiceContainer.executeDeploymentOperation(
	at org.camunda.bpm.container.impl.spi.DeploymentOperation$DeploymentOperationBuilder.execute(
	at org.camunda.bpm.container.impl.RuntimeContainerDelegateImpl.deployProcessApplication(
	at org.camunda.bpm.application.AbstractProcessApplication.deploy(
	at org.camunda.bpm.application.impl.ServletProcessApplication.contextInitialized(
	at org.apache.catalina.core.StandardContext.listenerStart(
	at org.apache.catalina.core.StandardContext.startInternal(
	at org.apache.catalina.util.LifecycleBase.start(
	at org.apache.catalina.core.ContainerBase.addChildInternal(
	at org.apache.catalina.core.ContainerBase.addChild(
	at org.apache.catalina.core.StandardHost.addChild(
	at org.apache.catalina.startup.HostConfig.deployDirectory(
	at org.apache.catalina.startup.HostConfig$
	at java.util.concurrent.Executors$
	at java.util.concurrent.ThreadPoolExecutor.runWorker(
	at java.util.concurrent.ThreadPoolExecutor$
Caused by: org.camunda.bpm.engine.ProcessEngineException: Cannot register service org.camunda.bpm.platform.job-executor.process-application:type=Rechenkern with MBeans Container, service with same name already registered.
	at org.camunda.bpm.container.impl.jmx.MBeanServiceContainer.startService(
	at org.camunda.bpm.container.impl.jmx.MBeanServiceContainer.startService(
	at org.camunda.bpm.container.impl.deployment.StartProcessApplicationServiceStep.performOperationStep(
	at org.camunda.bpm.container.impl.spi.DeploymentOperation.execute(
	... 18 more

It also happens when I build it “normal” an then change the server.xml of Tomcat like this:

<Context docBase="..." path="/myApp" reloadable="true" source="..."/>

Any hints what may causes this problem and how to fix it?

kind regards

My guess is that you already have a process with the “name” (key) of the process you are trying to deploy. Because you’re using a different war file name, Tomcat (I use WildFly) and Camunda probably think it’s a different process. However, the name of the war file does not mean the process is named differently.

Simply put, you can replace an existing process definition with a war file of the same name, but if you attempt to replace it (even inadvertently) with a war file of a different name, it will fail.

Be sure that the name of the process (which is actually called the “key”) is not present on your Camunda server.

I tried to remove all deployments and with a totally clean database. Same error.

It is related to some configuration which is may missing in eclipse set up, but I can’t find the problem.